Error deploying App to Google Play Store


#1

I am trying to deploy an app to Google Play and it keeps failing with the error 'You need to use a different package name because ‘com.example’ is restricted.

However my package name is not com.example. I have even created a new project with the following command…

ionic start --type ionic1 -a llfmobileapp -i com.llf.llfmobileapp llfmobileapp blank

there should be no references to com.example in the project I just created using the above command

after I created this 2nd project, I checked the files and I noticed that the ionic CLI placed the wrong the widget id in the config.xml, it was set to io.ionic.starter not the package name I specified. so i updated the config.xml with the package name that I want and then added the android platform with the following command…

ionic cordova platform add android

Then I checked my applicationManifest,xml and it now contains the proper package name and so does my config.xml

I built the code with both of these commands with the same result…

ionic cordova build --release android and cordova build --release android

The only code that I copied from my original project which had the same problem was the www folder. I have searched through all the code and can’t find a single reference to ‘com.example’.

Any ideas on how to resolve this?

thanks in advance…


#2

This problem has been resolved, thank you.


#3

Same result as what?[quote=“genedragotta, post:1, topic:90882”]
ionic start --type ionic1 -a llfmobileapp -i com.llf.llfmobileapp llfmobileapp blank
[/quote]

Is this the proper v3 CLI syntax?

How?