Error building Ionic app: Failed to execute aapt (CordovaLib:processDebugResources)

Hi all,

I’m trying to use Ionic framework to build hybrid mobile apps but i’m facing the following problem since a few days.

When I want to build the application (which is actually a blank project), the command “ionic cordova build android” returns this error (detailed logs below) when executing CordovaLib:processDebugResources task:
/home/pi/android-sdk/build-tools/23.0.1/aapt: Syntax error: newline unexpected (expecting ")")

I tried to reinstall many times Android SDK. I also tried differents versions of Android tools/platforms (23, 26) but it did nothing.

I didn’t find on the web any solution to solve this problem.
So, if someone has an idea or already faced this problem and solved it, do not hesitate :wink:

Thank you for your help.

  • Detailled logs when building the app:

      :CordovaLib:generateDebugBuildConfig UP-TO-DATE
      :CordovaLib:processDebugResources/home/pi/android-sdk/build-tools/23.0.1/aapt: 2:
      /home/pi/android-sdk/build-tools/23.0.1/aapt: Syntax error: newline unexpected (expecting ")")
      FAILURE: Build failed with an exception.
      * What went wrong:
      Execution failed for task ':CordovaLib:processDebugResources'.
      > Failed to execute aapt
      * Try:
      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
      Total time: 55.363 secs
      Error: /home/pi/IonicPJ/platforms/android/gradlew: Command failed with exit code 1 Error output:
      Picked up _JAVA_OPTIONS: -Xmx256M
      /home/pi/android-sdk/build-tools/23.0.1/aapt: 2: /home/pi/android-sdk/build-tools/23.0.1/aapt: Syntax error:
      newline unexpected (expecting ")")
      FAILURE: Build failed with an exception.
      * What went wrong:
      Execution failed for task ':CordovaLib:processDebugResources'.
      > Failed to execute aapt
  • You will find below different element concerning the components installed.

Ionic 3.8.1
Cordova 7.0.1
Gradle 4.1

I set the variables $JAVA_HOME, $ANDROID_HOME
and added $ANDROID_HOME/tools and $ANDROID_HOME/platform-tools to $PATH variable

This is the packages I installed via Android SDKManager:

Installed packages:

Path Version Description Location
build-tools;23.0.1 23.0.1 Android SDK Build-Tools 23.0.1 build-tools/23.0.1/
emulator 26.1.3 Android Emulator emulator/
extras;android;m2repository 47.0.0 Android Support Repository extras/android/m2repository/
extras;google;m2repository 57 Google Repository extras/google/m2repository/
patcher;v4 1 SDK Patch Applier v4 patcher/v4/
platform-tools 26.0.0 Android SDK Platform-Tools platform-tools/
platforms;android-23 3 Android SDK Platform 23 platforms/android-23/
platforms;android-25 3 Android SDK Platform 25 platforms/android-25/
tools 26.0.2 Android SDK Tools tools/

When I run “ionic cordova platform ls”, I have:
Installed platforms:
android 6.2.3

And everything is running on a raspberry with Raspbian Jessie:
Linux raspberrypi 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux

Is cordova requirements happy?
Can you try it with another new project created with ionic start blank blank?
Post your ionic info output please.

Here is the result of cordova requirements:

pi@raspberrypi:~/IonicPJ $ cordova requirements
Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: installed android-25,android-23
Gradle: installed /home/pi/gradle/gradle-4.1/bin/gradle

I created a new project and tried to build as follows:

`ionic start NewProject blank --type ionic1 => OK

cd NewProject/ => OK

ionic cordova platform add android => OK

ionic cordova build android => FAILED with the build error of my first post`

And finally, here is the result of ionic info:

cli packages: (/usr/lib/node_modules)
    @ionic/cli-utils  : 1.8.1
    ionic (Ionic CLI) : 3.8.1
global packages:
    Cordova CLI : 7.0.1
    Gulp CLI    : not installed globally
local packages:
    Cordova Platforms : android 6.2.3
    Ionic Framework   : ionic1 1.3.3
    Android SDK Tools : 26.0.2
    Node              : v8.2.1
    npm               : 5.3.0
    OS                : Linux 4.9