ERR_SDK_NOT_FOUND: No valid Android SKD root found

Hello people.
I’m working on a project with Ionic V4 for the first time. I want to run my app on an emulator and it keeps giving this error:
ERR_SDK_NOT_FOUND: No valid Android SDK root found.

I’ve tried running with various commands: native-run android, ionic cordova run android, ionic cordova run android --no-native-run, ionic run android but they all give the same error.

I ran ionic cordova requirements and I have all requirements (JDK, SDK, gradle) installed.
I need help with this and will appreciate any/all suggestions as this is quite urgent.

Did you manage to find a solution, I have the same issue and would love to resolve it…

Ionic info

Ionic:

Ionic CLI : 5.2.2

Utility:

cordova-res : 0.3.0
native-run : 0.2.4

System:

NodeJS : v12.2.0
npm : 6.9.0
OS : Windows 10

Did you followed all of the steps of the following Documentation?

What error do you get (more detailed)?

I think there is a path variable in your CLI messed up.

Cheers
Unkn0wn0x

It’s my first time with ionic and I have the same problem. I can build the apk with “ionic Cordova build android” but I can’t run on a device with “ionic Cordova run android --device”.

All time gets a message error:
[native-run] ERR_SDK_NOT_FOUND: No valid Android SDK root found.
[ERROR] An error occurred while running subprocess native-run.

I need help!
Thank you so much.

I just had this same problem. Manually running the command that the ionic CLI was failing on with a --verbose tag lead me to an iffy solution that works.

native-run android --app platforms/android/app/build/outputs/apk/debug/app-debug.apk --device --verbose

native-run was looking for the SDK at $HOME/Android/sdk
However, my SDK was stored at $HOME/Android/Sdk

I’m sure there’s a correct way to fix this problem. But as a bandaid for right now I just made a copy of the Sdk directory and put it in a directory called sdk.

2 Likes

You can try specifying Android SDK using this command on Linux:
export ANDROID_SDK_ROOT=$HOME/Android/Sdk