Email composer plugin not working


#1

I tried to install following plugin:

http://ngcordova.com/docs/plugins/emailComposer/

Error :
[javac] C:\Users\rajul\Documents\test\mymedisynApp\platforms\android\src\de
appplant\cordova\emailcomposer\EmailComposer.java:117: error: no suitable constr
uctor found for PluginResult(Status,List)
[javac] PluginResult result = new PluginResult(PluginResult.
Status.OK,messages);
[javac] ^
[javac] constructor PluginResult.PluginResult(Status,byte[],boolean) is
not applicable
[javac] (actual and formal argument lists differ in length)
[javac] constructor PluginResult.PluginResult(Status,byte[]) is not appl
icable
[javac] (actual argument List cannot be converted to byt
e[] by method invocation conversion)
[javac] constructor PluginResult.PluginResult(Status,boolean) is not app
licable
[javac] (actual argument List cannot be converted to boo
lean by method invocation conversion)
[javac] constructor PluginResult.PluginResult(Status,float) is not appli
cable
[javac] (actual argument List cannot be converted to flo
at by method invocation conversion)
[javac] constructor PluginResult.PluginResult(Status,int) is not applica
ble
[javac] (actual argument List cannot be converted to int
by method invocation conversion)
[javac] constructor PluginResult.PluginResult(Status,JSONObject) is not


#2

Installing with stable version solve this problem :

cordova plugin add de.appplant.cordova.plugin.email-composer@0.8.2


#3

It may be that the current version of cordova / ionic not allow install like this?

An alternative?

Thanks