** [done] Ionic app doesn't run or build

I’m trying to test my ionic application as a native app on android.
I’ve tried running the command below as per the ionic documentation
ionic cordova run android

I’ve also connected up my phone and enabled USB debugging. I get a bunch of output but the app doesn’t get installed onto my device.

I’ve also tried building the application for android but same error!!

cordova run android
(node:58469) UnhandledPromiseRejectionWarning: Error: spawn EACCES
at _errnoException (util.js:1003:13)
at ChildProcess.spawn (internal/child_process.js:340:11)
at Object.exports.spawn (child_process.js:499:9)
at Object.exports.spawn (/Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/node_modules/cordova-common/src/superspawn.js:134:31)
at GradleBuilder.runGradleWrapper (/Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/lib/builders/GradleBuilder.js:78:27)
at /Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/lib/builders/GradleBuilder.js:177:21
at _fulfilled (/Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/node_modules/q/q.js:854:54)
at self.promiseDispatch.done (/Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/node_modules/q/q.js:883:30)
at Promise.promise.promiseDispatch (/Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/node_modules/q/q.js:816:13)
at /Users/macbookpro/desktop/mobile/ionic/2018/vv/platforms/android/cordova/node_modules/q/q.js:570:49
(node:58469) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:58469) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

[OK] Your app has been deployed.
     Did you know you can live-reload changes from your app with --livereload?

I have remeved node, ionic and cordova and install them from the beginning and still did’nt work.

I had a quick look at your error, looks like it was often reported (see below)

I quickly went thru them, I kind of have the feeling that often the problem was

a. Too old plugins or cordova-android version


b. Having cordova-android@7.0.0 and using old plugins


c. Not having a local grade installed (actually I didn’t read that one but it’s also a classic one)


d. sometimes removing and adding the platform after having played with the plugins help (that one is also from me because I just had to do it :joy: )

Do one of these apply to your app?

I know probably not the answer you wanted to hear but maybe it could lead you to something, at least I hope it helps a bit.

Here the list of issues:


Thank you for your reply.

I’ve removed completely the nodejs, ionic and cordova … Then I reinstall them.
I start a new ionic project and the building was perfectly normal, but when I add Cordova AdMob Free to my project and I try to build for android the problem appears, but for ios it works perfectly and the ads show normal.

This is the link for this issue on Github: #155

If you can kindly guide me to solve this problem.
best regards.

According the issue you linked, someone found a solution, have you tried it?

See answer of @RenaudROHLINGER in https://github.com/ratson/cordova-plugin-admob-free/issues/155