Does Ionic works fine on M1 Macbooks?

Today my beloved intel i7 macbook pro 16 suddenly died, i already repaired it twice, its time to buy a new machine.
I was thinking of getting the M1 macbook pro 16, do you know if everything will work fine (xcode, android studio)?
Since I work a lot outside the office / house, my fear is buying a machine incompatible with all my current projects.

Thank you!

Yes! Ionic works well with M1. I used my iMac 2021 to run Apps on Android and iOS Devices using Live Reload. Sometimes Cocoa Pods makes some trouble on the installation Process. But there is a good workaround to install it without errors. All in all everything works great on M1.


1 Like

thank you so much for sharing your experience.
Luckily and (again) suddenly, when I was slipping the macbook just turned on :smiley:
i will try to resist a little more and wait for a macbook m2 pro maybe :slight_smile:


Hi Marius,

Could you please elaborate on the workaround you mentioned related to Cocoa Pods on the installation process? Or point me in the right direction? I seem to be running into this issue with an M1 MacBook - it hangs every time I try to build the app. Specifically, it gets stuck at “Updating iOS native dependencies with “pod install” (may take several minutes).”

Thank you so much!

It can take more than 5 minutes,
this is the solution that worked for me:

. I fixed the ffi issue by uninstalling my faulty Ruby version and CocoaPods, then I used the -x86_64 arch to reinstall ffi and CocoaPods.

These are the steps I did to get back to a working state (and to apply the M1 workarounds for ffi):

  1. Uninstall Ruby with: brew uninstall ruby --force
  2. Uninstall CocoaPods. At first, try to list all CocoaPods versions / components with gem list --local | grep cocoapods. Then uninstall them one by one, in my case:

sudo gem uninstall cocoapods

sudo gem uninstall cocoapods-core

sudo gem uninstall cocoapods-downloader


  1. As a next step I was able to reinstall ffi and then CocoaPods with:

sudo arch -x86_64 gem install ffi

sudo arch -x86_64 gem install cocoapods

Once done, I could run pod install as expected.
(maybe you will need to run pod update before)


For me, sudo arch -x86_64 gem install ffi didn’t work.

I ended up running the following (note that I am on a cloud Mac and I don’t have admin rights) (source):

gem install --user-install ffi -- --enable-libffi-alloc
gem install cocoapods --user-install

I believe this allows things to also stay with the M1 architecture and not emulate x86 too.

1 Like

This worked! Build time went from 3+ hours to just a few minutes. Thanks!

1 Like

For me, solution 1 of the following article worked well. Maybe it’ll be helpful for some people who come across this thread:

1 Like