Deploying APP to Nexus 6p Issues


#1

Hi,

So yesterday was the first time I deployed the app to the mobile and it worked well. Today I tried again and didn’t work.

Apparently I have no erros but the app dosen’t start on the phone …

Ionic Info

    @ionic/cli-utils  : 1.19.2
    ionic (Ionic CLI) : 3.20.0

global packages:

    cordova (Cordova CLI) : 8.0.0

local packages:

    @ionic/app-scripts : 3.1.8
    Cordova Platforms  : android 7.0.0
    Ionic Framework    : ionic-angular 3.9.2

System:

    Android SDK Tools : 26.1.1
    Node              : v8.9.4
    npm               : 5.6.0
    OS                : Windows 10

Environment Variables:

    ANDROID_HOME : D:\Programas\AndroidSDK

Misc:

    backend : pro

I also tryed a simple app in Android Studio and deployed to the phone, the Log Cat returns with this error when it tries to deploy to the phone :

E/QC-QMI: linux_qmi_qmux_io_wake_unlock: Err in writing wakelock=qmuxd_port_wl_0, error [1:Operation not permitted]

I also created a new ionic tabs app with an older version of cordova Android and it won’t depoy

Can’t find a solid solution to the log cat error…

Any ideas/solutions ?

Thanks


#2

There is a newer version of cordova-android, 7.1.0. Try that one.
Also try other devices if you have any.


#3

Hi,

I already tried other Android device and the app deploys with no errors …

I will try with Cordova 7.1.0 and let you know

Thanks.


#4

Did not work as well, any more suggestions ? Thanks.


#5

Then find out what is special with that device. Also google for the error message you posted above, maybe this leads you to the solution.