Dependencies to build for android 4.0.3

Hello :slight_smile:

I’m currently trying to build an app for 4.0.3

I installed the latest ionic and cordova version and added crosswalk version 19
also
in the config.xml I added
< preference name=“android-minSdkVersion” value=“14” />
< preference name=“android-targetSdkVersion” value=“23” />

but it seems not to work.

I know that the cordova-android version is too high ( https://cordova.apache.org/docs/en/latest/guide/platforms/android/index.html ), but when i try to add a lower cordova-android-version e.g. 5.X.X i get an error that the sdk is not found.

 ANDROID_HOME=C:\Android\sdk
        JAVA_HOME=C:\Program Files\Java\jdk1.8.0_144
        Error: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
        Looked here: C:\Android\sdk\tools\templates\gradle\wrapper

the solution is to upgrade to the newest cordova-android version,but then i cant use crosswalk19
Any ideas ? Please :slight_smile:

Edit: Or in other words: which ionic and cordova version supports crosswalk version19?

Edit2: https://stackoverflow.com/questions/42613882/error-could-not-find-gradle-wrapper-within-android-sdk-might-need-to-update-yo so it could be, because of the android build tools

So I tried this:


npm install ionic
npm install cordova@6.X.X

ionic start hello (I choosed tabs)
cd hello


ionic cordova plugin add cordova-plugin-crosswalk-webview@1.8.0 (Crosswalk at Releace 1.8 supports Android 4.0)
ionic cordova platform add android@5.X.X (I think I need cordova-android below Version 6 to support API 15)

Then I looked in the config.xml and there was <preference name="android-minSdkVersion" value="16"/> but I need API15, so I removed the line.

I thought now, lets try it:
ionic cordova build android
this was the result:

BUILD SUCCESSFUL

Total time: 46.72 secs
Built the following apk(s):
        C:/Users/XX/Desktop/hello/platforms/android/build/outputs/apk/android-armv7-debug.apk
        C:/Users/XX/Desktop/hello/platforms/android/build/outputs/apk/android-x86-debug.apk

But when I run the app in an emulator (API15) the app opens and I see the loading symbol, but is crashing then.

AndroidManifest.xml uses the right Version as mentioned from Cordova https://cordova.apache.org/docs/en/latest/guide/platforms/android/index.html

 <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="23" />

ionic info


cli packages: (C:\Users\XX\AppData\Roaming\npm\node_modules)

    @ionic/cli-utils  : 1.9.2
    ionic (Ionic CLI) : 3.9.2

global packages:

    Cordova CLI : 6.5.0

local packages:

    @ionic/app-scripts : 2.1.4
    Cordova Platforms  : android 5.2.2
    Ionic Framework    : ionic-angular 3.6.0

System:

    Android SDK Tools : 25.2.5
    Node              : v6.11.2
    npm               : 3.10.10
    OS                : Windows 10

Please any ideas with this informations? I think it´s maybe the wrong ionic version, but which should I use instead?

https://github.com/ionic-team/ionic-conference-app/issues/184
try crosswalk

I tried already crosswalk …

I am not sure there is a way to get this running on 4.0.x - Crosswalk also only support 4.1 and up.

Why do you need this super old Android version?

I need to run the app specific on one device that only supports Android 4.0.4

Edit: Crosswalk Version 19 was the last version which supports Android 4.0

I would ask on slack.cordova.io in #cordova-android if there is a way to get Cordova running on this old version and what exactly has to be done.