Dependencies for Cloud Client?


#1

I’m just trying to get a basic ionic2 app going. Starting the app is working fine, however when I begin to follow the instructions at https://docs.ionic.io/setup.html

npm install @ionic/cloud-angular --save

I get the the following:

±- UNMET PEER DEPENDENCY @angular/core@>=2.0.0-rc.0 <2.0.0-rc.5
-- @ionic/cloud-angular@0.4.0@ionic/cloud@0.9.0
-- superagent@1.8.4 +-- component-emitter@1.2.1 +-- cookiejar@2.0.6 +-- form-data@1.0.0-rc3 |– async@1.5.2
±- formidable@1.0.17
±- methods@1.1.2
±- mime@1.3.4
±- qs@2.3.3
±- readable-stream@1.0.27-1
`-- reduce-component@1.0.1

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.14
npm WARN @ionic/cloud-angular@0.4.0 requires a peer of @angular/core@>=2.0.0-rc.0 <2.0.0-rc.5 but none was installed.


#2

Problem solved… looks like I was just a bit early. A new cloud client was released a few hours after this post that works with the latest ionic (which I am using). All good!


#3

what version of ionic-angular are you using? I am facing a different issue (discussed here: Ionic 2 RC0 - Authentication with Cloud Angular or ng2 Cordova not working) and was wondering how you got cloud-angular working.