@ionic/cloud-angular@0.7.0 requires a peer of @angular/core@^2.0.0 but none was installed


#1

how to solve this problem


#2

What’s your package.json?


#3

And ionic info please?


#4

global packages:

@ionic/cli-utils : 1.1.2
Cordova CLI      : 7.0.1 
Ionic CLI        : 3.1.2

local packages:

@ionic/cli-plugin-cordova : 1.1.2
@ionic/cli-plugin-ionic1  : 1.1.2
Ionic Framework           : ionic1 1.0.0-rc.3

System:

Node       : v6.10.3
OS         : Linux 4.4
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed

#5

Ah, now I see it.

You are trying to use @ionic/cloud-angular which is a library for Ionic2+/Angular2+ - but your project is Ionic v1. You need to use @ionic/cloud as described here: https://docs.ionic.io/setup.html (switch to “Framework: Ionic 1” on the top left)


#6

{
“name”: “Test”,
“version”: “1.0.0”,
“description”: “Test: An Ionic project”,
“dependencies”: {
"@ionic/cloud-angular": “^0.7.0”,
“bluebird”: “^3.4.6”,
“cordova-android”: “^6.2.3”,
“cordova-plugin-compat”: “^1.1.0”,
“cordova-plugin-console”: “^1.0.7”,
“cordova-plugin-device”: “^1.1.6”,
“cordova-plugin-facebook4”: “^1.7.4”,
“cordova-plugin-file”: “^4.3.3”,
“cordova-plugin-ios-camera-permissions”: “^1.0.5”,
“cordova-plugin-media-capture”: “^1.4.3”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.3”,
“cordova-plugin-whitelist”: “^1.3.2”,
“gulp”: “^3.5.6”,
“gulp-concat”: “^2.2.0”,
“gulp-jade”: “^1.0.0”,
“gulp-minify-css”: “^0.3.0”,
“gulp-rename”: “^1.2.0”,
“gulp-sass”: “^2.0.0”,
“gulp-shell”: “0.4.2 “,
“gulp-uglify”: “^1.0.0”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ng-img-crop-full-extended”: “^0.6.1”
},
“devDependencies”: {
@ionic/cli-plugin-cordova”: “1.1.2”,
"@ionic/cli-plugin-ionic1": “1.1.2”,
“bower”: “^1.3.3”,
“cordova”: “^4.3.0”,
“eslint”: “^1.10.2”,
“eslint-config-angular”: “^0.4.0”,
“eslint-plugin-angular”: “^0.14.0”,
“gulp-eslint”: “^1.1.1”,
“gulp-sass”: “^2.0.4”,
“gulp-shell”: “^0.4.2”,
“gulp-unzip”: “^0.1.3”,
“gulp-util”: “^3.0.6”,
“ionic”: “^1.3.19”,
“shelljs”: “^0.3.0”,
“vinyl-request”: “^0.1.0”,
“yargs”: “^3.25.0”
},
“cordovaPlugins”: [
{
“locator”: “https://git-wip-us.apache.org/repos/asf/cordova-plugin-globalization.git”,
“id”: “cordova-plugin-globalization”
},
{
“locator”: “https://git-wip-us.apache.org/repos/asf/cordova-plugin-device.git”,
“id”: “cordova-plugin-device”
},
“cordova-plugin-crosswalk-webview”,
“cordova-plugin-whitelist”,
“cordova-plugin-splashscreen”,
“cordova-plugin-googleplayservices”,
“cordova-plugin-statusbar”,
{
“locator”: “https://github.com/EddyVerbruggen/SocialSharing-PhoneGap-Plugin.git”,
“id”: “cordova-plugin-x-socialsharing”
},
{
“locator”: “https://github.com/whiteoctober/cordova-plugin-app-version.git”,
“id”: “cordova-plugin-app-version”
},
{
“id”: “org.apache.cordova.crashlytics”,
“locator”: “https://github.com/smistry-toushay/cordova-crashlytics-plugin.git”,
“variables”: {
“CRASHLYTICS_API_KEY”: “”,
“CRASHLYTICS_API_SECRET”: “”
}
},
“cordova-plugin-camera”,
“cordova-plugin-screen-orientation”,
“ionic-plugin-keyboard”,
“cordova-plugin-network-information”,
“cordova-plugin-file-transfer”,
“cordova-plugin-file”,
“cordova-plugin-zip”,
“cordova-plugin-inappbrowser”,
“cordova-plugin-google-analytics@1.6.0”,
{
“variables”: {
“APP_ID”: “”,
“APP_NAME”: “YuuZoo”
},
“locator”: “cordova-plugin-facebook4”,
“id”: “cordova-plugin-facebook4”
}
],
“cordovaPlatforms”: [
{
“platform”: “browser”,
“version”: “”,
“locator”: “browser”
},
“ios”,
{
“platform”: “ios”,
“version”: “”,
“locator”: “ios”
},
“android”
],
“cordova”: {
“plugins”: {
“cordova-plugin-facebook4”: {
“APP_ID”: “”,
“APP_NAME”: “Test”
},
“cordova-plugin-ios-camera-permissions”: {},
“cordova-plugin-media-capture”: {},
“cordova-plugin-device”: {},
“cordova-plugin-console”: {},
“cordova-plugin-whitelist”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“ionic-plugin-keyboard”: {}
},
“platforms”: [
“android”
]
}
}


#7

thank you
i have i query on ionic
i have installed ionic@2.2.1, cordova@6.0.0, node v6.10.3,
gulp
[17:55:26] CLI version 3.9.1
[17:55:26] Local version 3.9.1,
npm 3.10.10
and when i give the following command

“ionic start i2c6 blank --v2”

i creates the project with ionic framework 3.2.1

“ionic info” result is

Cordova CLI: 6.0.0
Ionic Framework Version: 3.2.1
Ionic CLI Version: 2.2.3
Ionic App Lib Version: 2.2.1
Ionic App Scripts Version: 1.3.7
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Linux 4.4
Node Version: v6.10.3
Xcode version: Not installed

is this project is ionicv2 project or ionicv3 project

please answer me


#8

How is this related to the original question? If this is something new, create a new topic. Please, also structure your post better and mark code or output as such. Thank you.


#9