Cordova CLI 8.0.0 released


#1

https://cordova.apache.org/news/2017/12/18/tools-release.html

Release highlights:

CB-13056: removed support for WebOS, BlackBerry10, and Ubuntu
CB-13057: removed cordova save command. This command isn’t needed as cordova auto saves dependencies.
CB-13055: removed --nofetch flag. Now all of our dependency fetching happens via cordova-fetch. This allowed us to drop the npm@2 dependency we were shipping with cordova. Instead, we now just use your system npm to do all of our fetching.

Who wants to be guinea pig and update right now?


#2

Great to hear this.
Yes, it’s about time to remove Blackberry OS… no one uses Blackberry anymore.
Blackberry filed bankruptcy many years ago.


#3

Guinea pig here :wink:

No worries, update is straight forward, no problem (full test done: update cordova / build iOS and android / run app on real devices)

p.s.: I use android@6.4.0 and ios@4.5.4


#4

…and they released some plugins to drop the support of these platforms too

https://cordova.apache.org/news/2017/12/20/plugins-release.html


#5

I may be wrong, but I’ve the feeling that if you use a cordova-android version < 7 you won’t be able to upgrade these freshly released plugins.

I could still not upgrade to 7 (some plugins aren’t compatible) and when I fetched the camera plugin I saw following warning

Fetching highest version of cordova-plugin-camera that this project supports: 3.0.0 (latest is 4.0.0)


#6

Yep saw that too. And…

Failed to install 'ionic-plugin-keyboard': Error: ENOENT: no such file or directory, open 'C:\Users\admin\Desktop\testtttttt\platforms\android\AndroidManifest.xml'

Tried this with a brand new clean (empty) project

ionic -v 3.19.0
cordova -v 8.0.0
npm -v 5.6.0
"cordova-android": “7.0.0” edit/added


#7

Yes, that is expected as these plugins also make sure you update to the new version as they are built for the new version and use functionality of it.


#8

The relevant thing you didn’t post is your cordova-android version. I suspect it is 7.x, which changed some stuff about the paths of the Android project (AndroidManifest.xml is now one level deeper in app). ionic-plugin-keyboard doesn’t seem to have been updated for that yet.


#9

Don’t know if it’s linked with this error, but I just noticed a ios-deploy warning after having build my iOS platform (even if everything was working fine)

Anyway I installed a fresh ios-deploy (same version) and warning disappeared. Maybe something was wrong with a simelink or something. Anyway all good.