CodeSign failed in target 'CapacitorCordova' from project 'Pods' while running in live reload

This behaviour happens since I upgraded to macOS 14.0 Sonoma.

I have a 2020 MacBook Pro M1

Xcode version 15.0

Ionic Framework Version


Current Behavior

When I try to run the project in live-reload mode and the app will give me an error:

[capacitor] The following build commands failed: 
[capacitor] CodeSign /<MyPath>/ios/DerivedData/<SimulatorId>/Build/Products/Debug-iphonesimulator/CapacitorCordova/Cordova.framework (in target 'CapacitorCordova' from project 'Pods') 
[capacitor] (1 failure)

Expected Behavior

Should open the simulator with the app, and when I make changes in the files it will reflect in the simulator.

Steps to Reproduce

Install a fresh, blank, ionic and vue project with:

ionic start

Install android and ios:

npm install @capacitor/android
npx cap add android

npm install @capacitor/ios
npx cap add ios

Then I do a pod install:

cd ios/App
pod install

Set up the script in package.json:

// package.json
"scripts": {
  . . .
+    "ios": "ionic cap run ios -l --external"
  . . .

Then I finally run

npm run build
npm run ios

I select the simulator for iPhone 15

At this point I get the error:

[capacitor]         The following build commands failed:
[capacitor]         CodeSign /<MyPath>/ios/DerivedData/<SimulatorId>/Build/Products/Debug-iphonesimulator/CapacitorCordova/Cordova.framework (in target 'CapacitorCordova' from project 'Pods')
[capacitor]         (1 failure)

same happens if I run just:

npx ionic cap run ios -l --external

To make sure that the code is runnable I open Xcode with:

npx ionic cap open ios

I select iPhone 15, press start, the simulator opens and the app works.

Ionic Info


Ionic CLI : 7.1.1 (/usr/local/lib/node_modules/@ionic/cli)
Ionic Framework : @ionic/vue 7.5.0


Capacitor CLI : 5.5.0
@capacitor/android : 5.5.0
@capacitor/core : 5.5.0
@capacitor/ios : 5.5.0


cordova-res : not installed globally
native-run : 1.7.3


NodeJS : v20.4.0 (/usr/local/Cellar/node/20.4.0/bin/node)
npm : 9.7.2
OS : macOS Unknown

Additional Information

My package.json at this point in the project:

"scripts": {
    "dev": "vite",
    "build": "vue-tsc && vite build",
    "ios": "ionic cap run ios -l --external",
    "preview": "vite preview",
    "test:e2e": "cypress run",
    "test:unit": "vitest",
    "lint": "eslint"
"dependencies": {
    "@capacitor/android": "^5.5.0",
    "@capacitor/app": "5.0.6",
    "@capacitor/core": "5.5.0",
    "@capacitor/haptics": "5.0.6",
    "@capacitor/ios": "^5.5.0",
    "@capacitor/keyboard": "5.0.6",
    "@capacitor/status-bar": "5.0.6",
    "@ionic/vue": "^7.0.0",
    "@ionic/vue-router": "^7.0.0",
    "ionicons": "^7.0.0",
    "vue": "^3.2.45",
    "vue-router": "^4.1.6"
"devDependencies": {
    "@capacitor/cli": "5.5.0",
    "@vitejs/plugin-legacy": "^4.0.2",
    "@vitejs/plugin-vue": "^4.0.0",
    "@vue/eslint-config-typescript": "^11.0.2",
    "@vue/test-utils": "^2.3.0",
    "cypress": "^12.7.0",
    "eslint": "^8.35.0",
    "eslint-plugin-vue": "^9.9.0",
    "jsdom": "^22.1.0",
    "typescript": "^5.1.6",
    "vite": "^4.3.9",
    "vitest": "^0.32.2",
    "vue-tsc": "^1.0.24"

Pod version: 1.13.0

Ruby version: ruby 2.6.10p210 (2022-04-12 revision 67958) [universal.arm64e-darwin23]

Did you come up with a solution? I’m getting exactly the same error here.

Nope. Unfortunately I have no idea. I have to open Xcode and run the project again with the play button every time I make a change.

1 Like

I have the same issue after upgrading to Sedona, any updates?

Try a Clean/Rebuild and Removing Derived Data.

Same here. Clean build and removing derived data didn’t help.

Has anyone been able to solve this yet? I am having the exact same issue.

It appears that whenever xcodebuild runs, it removes the automatic code signing for the cocoa pods. Even when I go into Xcode and re-enable it, it will get overwritten when xcodebuild runs. Researching solutions now…

@opfilip I saw that you opened an issue on GitHub and it got shut down. Did you every find a way to get live reload working on an ARM Mac?