CLI >3.8: livereload.js?snipver=1 net::ERR_CONNECTION_TIMED_OUT

As soon i removed cli-plugin-cordova I started getting error:
And I am unable to remove this error even after adding the plugin back.

livereload.js?snipver=1 net::ERR_CONNECTION_TIMED_OUT

Can anyone help please ?

What is your ionic info output?

    @ionic/cli-utils  : 1.9.1
    ionic (Ionic CLI) : 3.9.1

global packages:

    Cordova CLI : 7.0.1

local packages:

    Cordova Platforms : android 6.2.3 ios 4.4.0
    Ionic Framework   : ionic1 1.3.3


    Android SDK Tools : 26.0.2
    Node              : v6.11.0
    npm               : 3.10.10
    OS                : Windows 10

I have upgraded to 3.9.1 but the problem is still there

Does it also happen if you start a new project and serve there?
Is it loading the file from the correct or wrong host?
Can you change the file URL so that is loads correctly? What do you have to change?

Host is correct and it does load the project in browser only with some lagging… and after changing the project code I have to manually reload the project code by hitting refresh and it does load but with the same error and some lagging…

I did try the same thing on a new example project and it is doing the same… so i created another project to conflict with
livereload port and got an error…

... Uhoh. Got error listen EADDRINUSE :::35729 ...
Error: listen EADDRINUSE :::35729
    at Object.exports._errnoException (util.js:1018:11)
    at exports._exceptionWithHostPort (util.js:1041:20)
    at Server._listen2 (net.js:1258:14)
    at listen (net.js:1294:10)
    at Server.listen (net.js:1390:5)
    at Server.listen (C:\Users\harariya\AppData\Roaming\npm\node_modules\ionic\node_modules\tiny-lr\src\server.js:244:19)
    at C:\Users\harariya\AppData\Roaming\npm\node_modules\ionic\node_modules\@ionic\cli-utils\lib\livereload.js:10:18
    at next (native)
    at fulfilled (C:\Users\harariya\AppData\Roaming\npm\node_modules\ionic\node_modules\tslib\tslib.js:93:62)
    at process._tickCallback (internal/process/next_tick.js:109:7)

You already have a server listening on 35729
You should stop it and try again.

then i stopped serve for first eg project and continued on second the new error log was gone but still facing the same old error with same old livereload lagging

No, I meant of the livereload.js - is this loading it from the correct host? What host is it?

c:\Users\harariya\Desktop\Main\eg1>ionic serve
[INFO] Starting server (address:, port: 8100, livereload port: 35729) - Ctrl+C to cancel
[INFO] Development server running
       Local: http://localhost:8100

<script src="//" async="" defer=""></script>
why is it loading from external host ? Is it normal?

I am not sure, might be a Ionic v1 problem. Have you checked the Ionic CLI issues on Github already?

So can not be opened, correct?
Can you open http://localhost:35729/livereload.js?snipver=1? says site cannot be reached but silver lining is
http://localhost:35729/livereload.js?snipver=1 works and gives out a very lengthy code is local LAN IP by the way.

Does work for you and show the same thing as http://localhost:8100 when running ionic serve?
Is your computers internal network IP?
Do you have a firewall or anything running that might block requests to specific ports?

No is not reachable… is internal ip , no firewalls … livereload still runs in my system once i take version back to 3.6

Ok, so that IP is not reachable from your local computer - although it is yours.

Is this your computer’s IP? You should be able to reach that then…
How are you connected to the internet? Wifi? Is “Make this PC discoverable” turned on in your network’s settings in Windows?

What URL is 3.6 using for the file?

Interesting… This is what I get with 3.6
<script src="//localhost:35729/livereload.js?snipver=1" async="" defer=""></script>

Starting server: --port=8100 --p=8100 --livereload-port=35729 --r=35729 --address= - Ctrl+C to cancel
[INFO] Development server running
       Local: http://localhost:8100
1 Like

Problem solved after updating to 3.9.2
It is back to :slight_smile:

<script src="//localhost:35729/livereload.js?snipver=1" async="" defer=""></script>

Thank you @Sujan12

1 Like

Ha, your second to last post told us what exactly was going wrong. And obviously 3.9.2 already got a fix for this :slight_smile:

Glad this was fixed for you. Happy development.


I was using a different wifi in the computer than in the device …