Can't start app in iPhone simulator


#1

I’'m following the getting started guide. When I run ios build the build completes successfully.
When I do sudo ionic emulate ios (by the way, all the examples seem to need admin privileges) the emulator opens with black screen and not fully loading the os. Then after a while I get the following error:

ENOENT: no such file or directory, stat '/Users/ophir/Library/Logs/CoreSimulator/2B899A4A-0811-47A0-BDB0-7DCDB918EC33/system.log’
Error code 1 for command: ios-sim with args: launch,/Users/ophir/Documents/Ionic/pushNotifications/platforms/ios/build/emulator/HelloCordova.app,–devicetypeid,com.apple.CoreSimulator.SimDeviceType.iPhone-6,–stderr,/Users/ophir/Documents/Ionic/pushNotifications/platforms/ios/cordova/console.log,–stdout,/Users/ophir/Documents/Ionic/pushNotifications/platforms/ios/cordova/console.log,–exit
Error: /Users/ophir/Documents/Ionic/pushNotifications/platforms/ios/cordova/run: Command failed with exit code 2


#2

Try to rebuild the project by executing ionic state reset command?
This will rebuild the project files.


#3

I don’t know if you have solved this yet but for me making the project files owned by my user account using chown sorted this