Can't run the command "ionic run ios"

I’m struggling to run my ionic app on my iPhone from the “ionic run ios”.
However, it well works if I make use of xCode directly to run the app on my device.

My provisioning files are valid (green icon) and there are no problems using Xcode directly.

When I run the ionic command, I get this:

Check dependencies
Code Sign error: No matching provisioning profile found: Your build settings specify a provisioning profile with the UUID “31e9e9bb-8da1-48c6-9256-ec365145a0ac”, however, no such provisioning profile was found.
CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 7.1'

My build settings contain:

I tried to select each possible provisioning profile in the highlighted section on the screenshot, but in vain.

I refreshed all the profiles thanks to the button on the bottom:

Has someone ever faced this scenario?

How could I fix it? It’s very frustrating :wink:

Thanks a lot,


I found the trick !

Even if I don’t figure out why until now:
The solution was to run the following command: sudo cp -r ~/Library/MobileDevice/ /Library/MobileDevice/

Does anyone figure out the necessity to make this copy?


I actually had the same problem. I don’t know even know how that happened because I uploaded another app to my phone and it actually worked but then tried to upload another one and it didn’t.

It works now after I ran that command.