Can't package build ios production


#1

Alright, running into a wall with this.

I’ve followed the instructions, created both dev and prod certificates, with corresponding dev and prod provisions. I can get the dev build working no problem.

  1. Got a prod and dev profile. Both have the provisions and cert as needed.
    Development ones for the dev, and Production for the prod.

Again, dev works fine, however prod fails with this

Code Sign error: No matching provisioning profiles found: No provisioning profiles matching an applicable signing identity were found.```

I've set the build settings in Xcode as well to match, Dev profiles and cert for the debug and Prod profiles and cert for the Release. As well as set the team...I'm so lost here.

#2

Facing the a similar problem right now. Never had this issue before though, a previous version of our app is already in the app store.
(you get this error locally if you don’t add a code signing identity in the xcode project, but local builds are working fine)


#3

So do you think this may have been an RC update issue?

I can do local build -dev and -prod no problem.


#4

I suspect it might be related to the latest iOS (and matching Xcode) version (10.2). Maybe the build settings or profile setup should be done differently now.
However, the weird thing is that I have another Ionic app (development version) which does still work. Nothing changed on either project.
The xcode project for which building an app is working has different (possible) settings under Signing in the Build Settings tab. The newest one (not working) also shows Code Signing Identity.


#5

Ended up just archiving the --prod build app using xcode. No issues with certificates or signing through that way. App is being review at the moment.


#6

Kk, thanks for the advice. Worked for me archiving and uploading via Xcode as well. Ionic package build still doesn’t work though.


#7

I’m on ionic-cli 3.0.0-beta5, I had to add following script to package.json

“build-prod”: “ionic-app-scripts clean && cordova clean && ionic cordova:build ios --prod --device --release --buildConfig ./build.json”

also add your cordova build.json at project root, refer to https://cordova.apache.org/docs/en/latest/guide/platforms/ios/

the resulting ipa will locate at platforms/ios/Build/device


#8

I don’t have the same error, however I have found the service quite sporadic - there seems to be no support for it either - Ionic Services - Package/Cloud build does not respect the --prod flag


#9

I hope it will helpful to you all