Can't install pod in AppFlow

I’m trying to set up a build in AppFlow and am running into an issue with CocoaPods. I’ve seen the best practice described here, but it doesn’t seem to be working for us.

We do have a custom Podfile due to some strange interdependencies:

platform :ios, '9.0'
source ''
source ''
target 'Pacifica' do
        project 'Pacifica.xcodeproj'
        pod 'GGLInstanceID', '~> 1.2.1'
        pod 'TwilioVideo', '2.6.0'
        pod 'FirebaseMessaging', '~> 2.0.0'
        pod 'GPUImage', '0.1.7'

This gets copied into platforms/ios before pod installation. When I run pod install locally, it shows:

Analyzing dependencies
Downloading dependencies
Using FirebaseAnalytics (4.2.0)
... [other pods]

When I view the output in the AppFlow build, I see:

Analyzing dependencies
[!] Unable to find the Xcode project `/Users/ionic/builds/pacifica-app/pacifica/platforms/ios/Pacifica.xcodeproj` for the target `Pods-Pacifica`.
Command finished with error code 1: /Users/ionic/builds/pacifica-app/pacifica/ /Users/ionic/builds/pacifica-app/pacifica
Error: Hook failed with error code 1: /Users/ionic/builds/pacifica-app/pacifica/

It doesn’t look like it gets to the “Downloading dependencies” step. I can’t see any errors though, and I’m attempting to run the build with --verbose so I don’t know to determine what the actual error is. I have tried this with changing the platform to 8.1 and removing the Twilio source and pod, and it still doesn’t seem to get past this step.

Thanks for any help,


Should anyone stumble across this, the definition of “Pacifica.xcodeproj” did not line up with the name that was defined in the native config in AppFlow. Fixing that helped me get past this.