Can't install ionic-native


#1


#2

you need to update you ionic version… with the latest version of ionic, you will get rxjs@5.0.0-beta.6


#3

i got the same error


#4

can we see your package.json


#5
{
  "dependencies": {
    "@angular/common": "^2.0.0-rc.1",
    "@angular/compiler": "^2.0.0-rc.1",
    "@angular/core": "^2.0.0-rc.1",
    "@angular/http": "^2.0.0-rc.1",
    "@angular/platform-browser": "^2.0.0-rc.1",
    "@angular/platform-browser-dynamic": "^2.0.0-rc.1",
    "@angular/router": "^2.0.0-rc.1",
    "es6-shim": "^0.35.0",
    "firebase": "^3.0.4",
    "ionic-angular": "^2.0.0-beta.8",
    "ionic-native": "^1.3.0",
    "ionicons": "3.0.0",
    "reflect-metadata": "^0.1.3",
    "rxjs": "^5.0.0-beta.6",
    "zone.js": "^0.6.12"
  },
  "devDependencies": {
    "del": "2.2.0",
    "gulp": "3.9.1",
    "gulp-watch": "4.3.5",
    "ionic-gulp-browserify-es2015": "^1.1.0",
    "ionic-gulp-fonts-copy": "^1.0.0",
    "ionic-gulp-html-copy": "^1.0.0",
    "ionic-gulp-sass-build": "^1.0.0",
    "ionic-gulp-scripts-copy": "^2.0.0",
    "run-sequence": "1.1.5"
  },
// rest is for plugins

#6

looks like there are some issues here…


#7

thanks but i don’t find any response


#8

The simple solution is to roll back to a working version? you know all this stuff is in beta


#9

yeah. but with your github tutorial there is ionic-native, i’ll wait


#10

not really understanding your point here? if you utilize the same versions i have in my package.json you will have no problems.

that is the reason you have the ability to lock in specific versions in package.json to get consistent results across builds and development environments


#11

ok. great thanks, @aaronksaunders :heart_eyes:


#12

hey @fab try to create a new app, it done easyly. sorry for english:raised_hands:


#13

I had similar issue with another Angular 2 and typescript project. Issue is due to rxjs@5.0.0-beta.8 version which has unmet dependencies that npm install isn’t able to take care of.

Until the issue with latest rxjs@5.0.0-beta.8 version is resolved, you can change your package.json to use specific version rxjs@5.0.0-beta.6.

Alternatively try installing rxjs@5.0.0-beta.6 manually.
npm install rxjs@5.0.0-beta.6

I hope that helps