Can't deploy to ios w cordova-plugin-facebook4


#1

I’ve been struggling to deploy to iOS for months now to no avail. I can deploy to Android just fine. So I created a new project and was able to build iOS and deploy to an emulator. I kept adding plugins and deployed and it worked until I installed the facebook plugin and received the same error that I had been getting with my app:

The following build commands failed:
Ld build/Mundo.build/Debug-iphonesimulator/Mundo.build/Objects-normal/x86_64/Mundo normal x86_64
CreateUniversalBinary build/emulator/Mundo.app/Mundo normal i386\ x86_64
GenerateDSYMFile build/emulator/Mundo.app.dSYM build/emulator/Mundo.app/Mundo
(3 failures)
Error: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/laroca/Documents/Mundo/platforms/ios/cordova/build-debug.xcconfig,-project,Mundo.xcodeproj,-target,Mundo,-configuration,Debug,-sdk,iphonesimulator,-destination,platform=iOS Simulator,build,CONFIGURATION_BUILD_DIR=/Users/laroca/Documents/Mundo/platforms/ios/build/emulator,SHARED_PRECOMPS_DIR=/Users/laroca/Documents/Mundo/platforms/ios/build/sharedpch

[ERROR] An error occurred while running cordova build ios (exit code 1).

I have no idea why there appears to be the incompatibility between facebookplugin and iOS but if you create a new app and deploy to iOS it will stop working once you add the facebook4 plugin.

Please help.