Cannot understand "Can't resolve all parameters for page" Ionic 3 + Firebase

#1
Error: Uncaught (in promise): Error: Can't resolve all parameters for XXXPage: ([object Object], [object Object], [object Object], [object Object], [object Object], ?).

Where i have to take a look? .ts? .html? It’s being a little bit annoying when gives this kind of error because it aren’t explicit…

Thanks you so much

#2

Check your constructor and take out any dependency that you didnt import

#3

hello

i found solution this is because of ionic new version update. I Advise you to use second last version of plugin.

you can edit older version in your project package.json file
or
you can specify version at the installation time.

thank :slight_smile:

#4

Please try To Use Old Version … of Plugin : https://stackoverflow.com/a/54365080/3725226

#5

Sorry i dont understand you, i didnt update anything, just im programming with Ionic 3 + Firebase

UPDATE:

I added the firebase plugin 2 month ago… i didn’t do any change on the project

#6

When did u added plugin for firebase ?

1 Like
#7

Can you show your package.json file?

#8

Sure :slight_smile:

...
"dependencies": {
    "@angular/animations": "5.2.11",
    "@angular/common": "5.2.11",
    "@angular/compiler": "5.2.11",
    "@angular/compiler-cli": "5.2.11",
    "@angular/core": "5.2.11",
    "@angular/forms": "5.2.11",
    "@angular/http": "5.2.11",
    "@angular/platform-browser": "5.2.11",
    "@angular/platform-browser-dynamic": "5.2.11",
    "@ionic-native/core": "~4.17.0",
    "@ionic-native/splash-screen": "~4.17.0",
    "@ionic-native/status-bar": "~4.17.0",
    "@ionic/storage": "2.2.0",
    "angularfire2": "^5.1.0",
    "cordova-plugin-device": "^2.0.2",
    "cordova-plugin-ionic-keyboard": "^2.1.3",
    "cordova-plugin-ionic-webview": "^2.2.5",
    "cordova-plugin-splashscreen": "^5.0.2",
    "cordova-plugin-statusbar": "^2.4.2",
    "cordova-plugin-whitelist": "^1.3.3",
    "firebase": "^5.5.9",
    "ionic-angular": "3.9.2",
    "ionicons": "3.0.0",
    "rxjs": "^6.3.3",
    "rxjs-compat": "^6.3.3",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.26",
    "cordova-android": "~7.1.4"
  },
  "devDependencies": {
    "@ionic/app-scripts": "3.2.1",
    "@ionic/lab": "1.0.15",
    "typescript": "~2.6.2"
  },
  "description": "An Ionic project",
  "cordova": {
    "plugins": {
      "cordova-plugin-whitelist": {},
      "cordova-plugin-statusbar": {},
      "cordova-plugin-device": {},
      "cordova-plugin-splashscreen": {},
      "cordova-plugin-ionic-webview": {
        "ANDROID_SUPPORT_ANNOTATIONS_VERSION": "27.+"
      },
      "cordova-plugin-ionic-keyboard": {}
    },
    "platforms": [
      "android"
    ]
  }
}
#9

You have done a number of bad things to your mobile app.

You must not go beyond this firebase version for Ionic 3 app firebase": "4.8.2", and rxjs": "5.5.2",. You have used a very big rxjs-compat module. It is not recommended even for a web app. So nothing to say about the mobile app then. Hope you’ll remove those and use the mentioned versions.

#10
#11

Please open a new question. This question about firebase.

1 Like