Can't resolve all parameters for MyApp


#1

[UPDATE] problem solved, it was a faulty parameters in the constructor, removed, solved.

Hello,
am getting this error, and i cant seem to find the cause.
I’ve looked into some topics here and there, but i couldn’t find a solution for my problem.
here is screenshot:

the error in the browser console:

Uncaught Error: Can't resolve all parameters for MyApp: ([object Object], [object Object], [object Object], ?, [object Object]).
    at syntaxError (VM96378 vendor.js:100920)
    at CompileMetadataResolver._getDependenciesMetadata (VM96378 vendor.js:116001)
    at CompileMetadataResolver._getTypeMetadata (VM96378 vendor.js:115836)
    at CompileMetadataResolver.getNonNormalizedDirectiveMetadata (VM96378 vendor.js:115344)
    at CompileMetadataResolver._getEntryComponentMetadata (VM96378 vendor.js:116149)
    at VM96378 vendor.js:116130
    at Array.forEach (<anonymous>)
    at CompileMetadataResolver._getEntryComponentsFromProvider (VM96378 vendor.js:116129)
    at VM96378 vendor.js:116084
    at Array.forEach (<anonymous>)
syntaxError @ compiler.js:466
CompileMetadataResolver._getDependenciesMetadata @ compiler.js:15547
CompileMetadataResolver._getTypeMetadata @ compiler.js:15382
CompileMetadataResolver.getNonNormalizedDirectiveMetadata @ compiler.js:14890
CompileMetadataResolver._getEntryComponentMetadata @ compiler.js:15695
(anonymous) @ compiler.js:15676
CompileMetadataResolver._getEntryComponentsFromProvider @ compiler.js:15675
(anonymous) @ compiler.js:15630
CompileMetadataResolver._getProvidersMetadata @ compiler.js:15593
(anonymous) @ compiler.js:15081
CompileMetadataResolver.getNgModuleMetadata @ compiler.js:15072
JitCompiler._loadModules @ compiler.js:33542
JitCompiler._compileModuleAndComponents @ compiler.js:33503
JitCompiler.compileModuleAsync @ compiler.js:33419
CompilerImpl.compileModuleAsync @ platform-browser-dynamic.js:230
PlatformRef.bootstrapModule @ core.js:5446
284 @ main.ts:5
__webpack_require__ @ bootstrap 95fd409297642a3ebf6c:54
webpackJsonpCallback @ bootstrap 95fd409297642a3ebf6c:25
(anonymous) @ main.js:1


#2

My issue too. Stil haven’t resolved mine


#3

If you are testing the app in the browser, try testing on the mobile. you will be facing a lot of random errors in the browser. @Timotheus


#4

@hexation1 didn’t do any good. Pls. help. Thanks.


#5

Double check your imports, this might also happen if you are injecting without importing @Timotheus


#6

Yup already did. imports are complete. Still no good. @hexation1


#7

@Timotheus Try removing constructer’s parameters one by one ( the ones you added) and see whether its working or not.


#8

usually, it shows ‘?’ as the location of the parameter that has problem.


#9

Yup, and it says all. Don’t know why. @hexation1


#10

It seems that you are calling some data or something and it’s throwing an error!
Can you post your code here?


#11

Some Component not imported in .ts file .

Stop Ionice Serve

Then
Start IONIC server . It will show error


#12

Got it already. Had something to do with the npm package of font-awesome. So I downloaded the library instead and referenced the files in index.html


#13

Won’t that blow your app binary up with the all the icons, even the ones you don’t use? There are much more efficient ways of using FontAwesome in Ionic apps, but the details depend on what Angular version you’re using.