Cannot find module when building for android


#1

So I’ve had this problem for about a week now. Basically my project will work fine one day but when I get up the next day all of a sudden ‘ionic build android’ no longer works. It always says something along the lines of:

Cannot find module '_____'

Do you need to run 'npm install'?

The ‘_____’ part is different each day. Some days I get this error others days I don’t and it always lists a different module that I am missing. Today it’s a module called ‘is-stream’, I’ll post the error below:

I also made a stack overflow post on the same error but a different module it was complaining about:

Now, I’ve had this happen to me a couple more times listing different modules and I have learned how to fix it. At this point whenever I see this I basically have to make a new folder and run ‘ionic start tempApp blank’ in that folder, copy my www folder from my old project onto this fresh new project and then run ‘ionic build android’ on that and this usually fixes the problem.

At this point as you can imagine i’m getting pretty sick of doing this. Has anyone ran into this issue before? I need to get this fixed it is driving me up a wall.

Thank you.
-Matt


#2

Nevermind. The solution was silly. I was typing in 'npm install and I put the module in quotes and it didn’t need to be in quotes. I had also forgotten the other day I installed the AWS sdk using npm install so it wasn’t random I guess it was just missing modules.