Build fastlane error

hi i got error while building android app
although web deploy build built good

[13:38:28]: ▸ Date: 2020-03-31T13:38:28.206Z - Hash: 4de72f047c47f47e26e4 - Time: 89399ms
[13:38:28]: $ ionic info
[13:38:31]: ▸ Ionic:
[13:38:31]: ▸ Ionic CLI                     : 6.2.2 (/usr/local/nvm/versions/node/v10.19.0/lib/node_modules/@ionic/cli)
[13:38:31]: ▸ Ionic Framework               : @ionic/angular 5.0.4
[13:38:31]: ▸ @angular-devkit/build-angular : 0.803.25
[13:38:31]: ▸ @angular-devkit/schematics    : 8.3.25
[13:38:31]: ▸ @angular/cli                  : 8.3.26
[13:38:31]: ▸ @ionic/angular-toolkit        : 2.2.0
[13:38:31]: ▸ Cordova:
[13:38:31]: ▸ Cordova CLI       : 9.0.3 (cordova-lib@9.0.2)
[13:38:31]: ▸ Cordova Platforms : none
[13:38:31]: ▸ Cordova Plugins   : no whitelisted plugins (0 plugins total)
[13:38:31]: ▸ Utility:
[13:38:31]: ▸ cordova-res : not installed
[13:38:31]: ▸ native-run  : not installed
[13:38:31]: ▸ System:
[13:38:31]: ▸ Android SDK Tools : 26.0.1 (/opt/android-sdk)
[13:38:31]: ▸ NodeJS            : v10.19.0 (/usr/local/nvm/versions/node/v10.19.0/bin/node)
[13:38:31]: ▸ npm               : 6.13.4
[13:38:31]: ▸ OS                : Linux 4.14
[13:38:31]: Generating app manifest...
[13:38:31]: $ ionic deploy manifest
[13:38:34]: ▸ [OK] Appflow Deploy manifest written to ./www/pro-manifest.json!
[13:38:34]: ----------------------------------
[13:38:34]: --- Step: add_cordova_to_index ---
[13:38:34]: ----------------------------------
[13:38:34]: codova.js missing in index.html: adding it
[13:38:34]: Writing new index.html
[13:38:34]: codova.js successfully added to index.html
[13:38:34]: -----------------------------------
[13:38:34]: --- Step: build_android_cordova ---
[13:38:34]: -----------------------------------
[13:38:34]: Adding Android platform...
[13:38:34]: $ cordova platform add android --no-fetch
[13:38:35]: ▸ You have been opted out of telemetry. To change this, run: cordova telemetry on.
[13:38:35]: ▸ Unhandled error. ('Parsing /builds/itosoftco/amnasnad-lts/config.xml failed')
[13:38:36]: Successfully added Android platform
[13:38:36]: Building android...
[13:38:36]: $ cordova build android
[13:38:37]: ▸ You have been opted out of telemetry. To change this, run: cordova telemetry on.
[13:38:37]: ▸ No platforms added to this project. Please use `cordova platform add <platform>`.
+----------------------------+-----------------------+
|                    Lane Context                    |
+----------------------------+-----------------------+
| DEFAULT_PLATFORM           | ios                   |
| PLATFORM_NAME              | android               |
| LANE_NAME                  | android package_build |
| PROJECT_WEB_DIR            | www                   |
| DOWNLOAD_CREDENTIAL_EXISTS | false                 |
+----------------------------+-----------------------+
[13:38:38]: Shell command exited with exit status 1 instead of 0.

You have been opted out of telemetry. To change this, run: cordova telemetry on.
No platforms added to this project. Please use `cordova platform add <platform>`.


+------+-----------------------+-------------+
|              fastlane summary              |
+------+-----------------------+-------------+
| Step | Action                | Time (in s) |
+------+-----------------------+-------------+
| 1    | default_platform      | 0           |
| 2    | build_summary         | 0           |
| 3    | add_git_credentials   | 0           |
| 4    | detect_native_type    | 0           |
| 5    | get_web_dir           | 0           |
| 6    | modify_config_xml     | 0           |
| 7    | download_credential   | 0           |
| 8    | build_pro_app         | 143         |
| 9    | add_cordova_to_index  | 0           |
| 💥   | build_android_cordova | 4           |
+------+-----------------------+-------------+

[13:38:38]: fastlane finished with errors

Looking for related GitHub issues on fastlane/fastlane...

➡️  Possible to pass fastlane a .app or .zip?
    https://github.com/fastlane/fastlane/issues/330 [closed] 2 💬
    22 Sep 2016

➡️  s3 action failure after migrating to 1.3.0
    https://github.com/fastlane/fastlane/issues/318 [closed] 6 💬
    22 Sep 2016

/usr/local/bundle/gems/fastlane-2.143.0/fastlane_core/lib/fastlane_core/ui/interface.rb:153:in `shell_error!': [!] Shell command exited with exit status 1 instead of 0. (FastlaneCore::Interface::FastlaneShellError)

You have been opted out of telemetry. To change this, run: cordova telemetry on.
No platforms added to this project. Please use `cordova platform add <platform>`.

	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/helper/sh_helper.rb:80:in `sh_control_output'
	from /builds/itosoftco/amnasnad-lts/fastlane/actions/safe_sh.rb:27:in `run'
	from /builds/itosoftco/amnasnad-lts/fastlane/actions/build_android_cordova.rb:23:in `run'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:261:in `block (2 levels) in execute_action'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/actions/actions_helper.rb:50:in `execute_action'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:253:in `block in execute_action'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:227:in `chdir'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:227:in `execute_action'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:157:in `trigger_action_by_name'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/fast_file.rb:159:in `method_missing'
	from Fastfile:131:in `block (2 levels) in parsing_binding'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/lane.rb:33:in `call'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:49:in `block in execute'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:45:in `chdir'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/runner.rb:45:in `execute'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/lane_manager.rb:56:in `cruise_lane'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/command_line_handler.rb:36:in `handle'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/commands_generator.rb:108:in `block (2 levels) in run'
	from /usr/local/bundle/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
	from /usr/local/bundle/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
	from /usr/local/bundle/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:76:in `run!'
	from /usr/local/bundle/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/commands_generator.rb:349:in `run'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/commands_generator.rb:41:in `start'
	from /usr/local/bundle/gems/fastlane-2.143.0/fastlane/lib/fastlane/cli_tools_distributor.rb:119:in `take_off'
	from /usr/local/bundle/gems/fastlane-2.143.0/bin/fastlane:23:in `<top (required)>'
	from /usr/local/bundle/bin/fastlane:23:in `load'
	from /usr/local/bundle/bin/fastlane:23:in `<main>'
➡️  Trouble using fastlane / sigh on multi-user system
    https://github.com/fastlane/fastlane/issues/326 [closed] 13 💬
    08 Nov 2016

and 16111 more at: https://github.com/fastlane/fastlane/search?q=Shell%20command%20exited%20with%20exit%20status%201%20instead%20of%200.%0A%0AYou%20have%20been%20opted%20out%20of%20telemetry.%20To%20change%20this%2C%20run%3A%20cordova%20telemetry%20on.%0ANo%20platforms%20added%20to%20this%20project.%20Please%20use%20%60cordova%20platform%20add%20%3Cplatform%3E%60.%0A&type=Issues&utf8=✓

Running after script...
$ run "clean-up"
ERROR: Job failed: command terminated with exit code 1

1 Like

+1

Appflow giving this error on android build. Web build works fine

1 Like

I’m having the same issue, has anyone had any luck solving it?