Application error Ionic serve and run android using different ports why


#1

when I type ionic serve it runs on localhost/8100 but cordova run android runs on localhost:/8102 and displaying error
connection refused


#2

is not a Ionic command.

Still, we need to see the exact error to debug anything.


#3

Using this command only to run and was working fine but why now that I. Not getting why running on different ports


#4

Why should it run on the same port? These are two commands from two different command line tools from two different software projects.


#5

But then it should work why it is showing like err connection refused


#6

*sigh

What is showing “connection refused”?
Where exactly?
What exactly does it say?
Did it work before?


#7

Yes it worked before now only when I run in emulator it builds successfully but when I execute Cordova run in emulator it shows error connection refused fails to connect my ip/local host:8002


#8

Ok, you don’t want to answer my questions. That’s fine, then I don’t want to help you. Good luck.


#9

What answer u want from me I didn’t get u I just can. Send u a screenshot that is it