App won't start with latest beta anymore


#1

Hi there,

I have strange problem with the latest beta 4. If I run the app I get this message “window.Zone.symbol is not a function” in app.bundle,js and the page stay blank. All pages I have tried to load stays white and empty. I’ve googled the message but without luck.

Any ideas?


#2

Hi!

Check this commit. This should solve it I guess.


Can't start Android app after updating to beta.4
#3

Hi,

thank you for the help. Unfortunately it doesn’t help. May be I’m doing it wrong, but either I get problems because angular2-polyfills.js can not be found in build, or after copy it there, I got another errors.

I’ve tried to update zone.js to latest version and modified “zone.js/dist/zone-microtask” to “zone.js/dist/zone” that helped me to start the app in lab, but it fails on device and/or simulator.

Thanks


#4

Looks like you need to update your package.json and gulpfile as well to actually create the polyfills script.


#5

Thank you for help.

I’ve updated my package.json, but I have little experience with gulp. In your gulpfile example I can’t find any reference to polyfills. Can you give an advise how I can modify the file?

Also, I still can run the app in the browser without polyfills, but have to rename zone-microtask to zone. Its running in simulator too, but I miss placeholder text in login forms.

Thanks


#6

Hi,

You shouldn’t need to modify the gulpfile. The ionic-gulp-scripts-copy is what’s creating the polyfills script, and ionic-gulp-browserify-es2015 has taken over creation of the app.bundle.js.


#7

I have created new project and changed my package.json and gulpfile. The app runs in browser without problems and polyfills script is created too.

One strange thing is, why my forms are without placeholder text anymore? In browser anything works fine.

Many thanks for you help! You are a life saver :slight_smile: