App Store Connect - Xcode v. 14.0 - upload warning (Ionic 6 / Capacitor 4) - The app references non-public selectors "

i’ve updated Xcode and now when i upload my app i get this warning:

do you know what may cause it?

i’m using the following plugins:
@capacitor-community/apple-sign-in”: “^1.0.1”,
@capacitor-community/facebook-login”: “^3.4.0”,
@capacitor-community/stripe”: “^3.9.1”,
@capacitor/push-notifications”: “^4.0.1”,
@capacitor/splash-screen”: “^4.0.1”,
@codetrix-studio/capacitor-google-auth”: “github:CodetrixStudio/CapacitorGoogleAuth”,
@ionic-native/in-app-browser”: “^5.36.0”,
@ionic-native/market”: “^5.36.0”,
@ionic-native/screen-orientation”: “^5.36.0”,


Whenever this happens it’s because of one of the following reasons:

  1. Apple is not accepting submissions from the Xcode version you are using.
  2. Apple backend is down or presenting temporary issues.
  3. Bug on the Xcode version you are using.
  4. Your app is really using non-public selectors.

transform doesn’t look like a non-public API to me, so it’s probably one from 1 to 3

1 Like

thank you for your prompt reply.
I’ve tried to upload another app which doesn’t use any of the above plugins and i don’t get those warnings.

So now i’ve removed all the plugins and adding one by one, let’s see if i can find who’s the guilty guy :smiley:

i’ve found the guilty guy:

once removed it, I had no warnings from Apple Store.

I’ve updated to version 4.1.0 which is the latest but the warning still occurs.

@capacitor/push-notifications doesn’t use any non-public APIs, so the problem is still one from 1 to 3.
Sometimes Apple checks get false positives.

@capacitor/push-notifications doesn’t have any references to “ImageNotification” nor “transform”.
The reference is probably inside Apple’s UserNotifications framework, that the plugin imports.

1 Like

ImageNotification is something i’ve added to send push notification with images,
i’ve followed this tutorial

so i got this:


you were right,
if i completely remove any reference to “ImageNotification” it works without any warning.

What do you suggest to try? Because if I remove it, i won’t be apple to send push notification with images on iOS

I still think it’s a false positive on the validation, “transform” is a pretty generic word for being considered non-public API.
The code you added following that tutorial is minimal, so the warning probably comes from firebase iOS SDK, but I see no reports on firebase iOS SDK github repository.
Try updating to latest firebase SDK if you are not using it already.

The message looks like a warning, is it preventing you from publishing?

1 Like

I didn’t try to publish the app, just uploaded for TestFlight.
With the latest Firebase SDK (9.5) push notifications stopped working suddenly :smiley: so i think i’m gonna keep the current version right now.

removing Firebase/Messaging and installing version 9.0.0 solved the issue