App SDK not reflecting HTML/Javascript changes


#1

Hello All,

So I’ve tried googling this issue and it appears to go back several years but no one really has a solid answer for me other than “Create a New Project and Copy Everything over.”

I’d like to avoid spending the few hours doing that for every time I make a change in my app. I built my app using ionic build android, then opened the project in Eclipse to finish signing it with my keystore and to export the APK. The first time I did this, all worked fine.

However, ever since then, if I make HTML/Javascript/CSS changes (the entirety of my app basically), none of those changes are reflected in the new APK.

What I have tried based on googling this issue:

  1. Project > Clean
  2. Fix Android Properties
  3. Delete app from emulator and/or device
  4. Make changes to xml/or java files (these changes are always reflected, but still not the HTML/javascript/etc.)
  5. Making sure all android builder options are checked in the project properties.
  6. Deleting and reimporting the project into Eclipse

I’ve heard that creating an entirely new project and copying things over, or renaming all of your html/css/javascript files will make it work. But that sounds tedious an unnecessary. I feel like there has to be a way to force Eclipse to rebuild the entire project as if it has never been built before.

I’m just looking one last time for a solution other until I’m forced to spend the couple hours recreating a new project and copying things over. Just seems silly that I’ll have to do this task at least once for every new Ionic app I make.

Thanks!


#2

Are you running ionic build android every time before you build in Eclipse? What happens is the build command will copy the assets from the root www/ directory into the specific android build, so if you make changes later to the root www/ directory those changes will not appear until you run the ionic build command again.

I usually build with ionic serve which lets me preview my html/css/javascript in the browser for small changes until I’m ready to worry about a full build to an emulator or device.


#3

I had wondered about that. My only problem is that my Android/Eclipse environment is on a separate PC. I was trying to make some quick small changes into the Eclipse project itself. My situation isn’t ideal nor very common. So I guess I’ll have to copy the files from my Eclipse project back into my Mac ionic project and rebuild, then reimport it into Eclipse?

Is a re-import necessary every single time in my odd case? I could see how it would not be necessary if I was on the same machine and the files for the Eclipse project would be updated each time I ran ionic build android.

Thanks for the help, gnome. I believe I know what I need to do now to get around this. I really need to get my environments all on one machine at some point… just some external barriers to that for a while.


#4

If I were building on separate computers, I would be committing my source files into git and then pulling changes down to rebuild on the other computer. Keeping everything in git would make it relatively easy to keep different computers up to date, and then to run platform specific builds independently.

Eventually I would setup build jobs on a CI server like Jenkins to automate the building on separate platforms. Also you should know that you can use command line xcode to build an iOS app on non-mac platforms (linux and windows with bash). Just some thoughts, but spending time automating your workflow is always worth it in the end, from experience.


#5

I created an ionic project and have changed the index.html file form the projects root www folder as well as from platform-ios /www/ folder.

But when running the command ionic serve from project root folder , browser opened up, but the changes are not reflecting.

Whats wrong here?


#6

Sorry , it was my problem. When opened in Xcode , it was always referred to as platform -ios folder only.
instead of root folder www.

it got worked now…


#7

I tried following
Remove the android platform by the command
cordova platform rm android.
And then again install the android platform again
cordova platform add android.
It works correctly for me.
I am using ionic 3.0.0alpha version of ionic CLI


#8