App hits white screen when building iOS app with --prod flag


Hey everyone,

Ever since I updated @ionic/app-scripts": "1.0.0" in my package.json file, any time I try to build my ionic app using ionic build ios --prod, when I launch it on my device, it just hits a white screen and stops.

However, when I build it with ionic build ios, it installs and runs fine, but still gets the temporary white screen before going into the app. The issue with the temporary whitespace has been there ever since I’ve started working on this app and I’m not sure how to fix that either, but the primary issue is that when I run my build with the --prod flag, I get the white screen.

Here is a list of my dependencies:

"dependencies": {
    "@angular/common": "2.2.1",
    "@angular/compiler": "2.2.1",
    "@angular/compiler-cli": "2.2.1",
    "@angular/core": "2.2.1",
    "@angular/forms": "2.2.1",
    "@angular/http": "2.2.1",
    "@angular/platform-browser": "2.2.1",
    "@angular/platform-browser-dynamic": "2.2.1",
    "@angular/platform-server": "2.2.1",
    "@ionic/storage": "1.1.7",
    "@types/algoliasearch": "^3.18.0",
    "@types/jasmine": "^2.5.41",
    "@types/lodash": "^4.14.55",
    "@types/lodash.update": "^4.10.1",
    "algoliasearch": "^3.21.1",
    "angular2-autosize": "^1.0.1",
    "angular2-moment": "^1.0.0",
    "angularfire2": "^2.0.0-beta.7",
    "firebase": "^3.6.6",
    "ionic-angular": "2.0.0",
    "ionic-native": "2.4.1",
    "ionicons": "3.0.0",
    "lodash": "^4.17.2",
    "moment": "^2.17.1",
    "ng-semantic": "^1.1.13",
    "rxjs": "^5.0.3",
    "zone.js": "0.6.26"
  "devDependencies": {
    "@ionic/app-scripts": "1.0.0",
    "typescript": "2.2.1"

I’m also using node v6.6.0.

Anyone have any thoughts on the matter?


TypeScript 2.2.1 jumps out at me as a big red flag.


Even when I’ve tried earlier versions, it still does the same thing :confused:

When I go down as low as 2.0.9, I get tons of typescript issues coming from lodash and jasmine that require at least 2.1 :frowning:


I would try attaching to it with Safari’s debugger on a USB-connected Mac, reloading it, and inspecting the console. There might be some information in there.