App doesn't work anymore after Ionic CLI update


#1

Hello,

I made an Ionic CLI update 2 days ago. Before this update, my application works well, but now I did that, all the ionic elements (like ionic tags) and ionic modules (like ngCordova, …) doesn’t work anymore. I tried to uninstall and install the version I had before this update (so the 3.13.0), I tried to create a new project and put my www folder in the new project, but the problem still be there. Does anyone know how to solve that ?

Thank you for your answers


#2

Try

npm install --save --save-exact ionic@3.13.0

To return back to 3.13.0 and check if your app works again.


#3

I had the same problem and I found the solution at this post Android build broken after gradle dependencies update. Check it!


#4

I already did that but this didn’t solve the problem :confused:


#5

On Android Studio you have to update SDK Manager to Android Api Level 26 (Android 8.0)!!


#6

Can you provide some more information?

  • What is not working?

  • What errors are showing up?

Thanks in advance


#7

Thank you, I will check that. I can’t test now because I’m not at my office, but I’ll test tomorrow ! I saw your second post too : I’m using Apache cordova and the application will be deploy on android tablets with android 5.1.1 minimum.


#8

I don’t think it’s the gradle dependencies as a fix.
Probably something else.

For tomorrow provide your errors so we can help you further.


#9

Yes no problem :

So, I developp this application with Apache Cordova and Ionic. I had Ionic 3.13.0. But I did an update to the 3.15.2. Before this update, my application worked well. But now, all the components like <ion-header-bar> or <ion-toggle> for example don’t appear anymore on the application. Also, the ng directives don’t work anymore.

There are no errors displayed when I run the command : ionic serve --lab.

I already tried the command you show me in the previous answer. I also uninstalled NodeJS, npm, ionic and reinstall all. But this changed nothing.


#10

Are you working with a versioning system?
Maybe you can just do a rollback to the older version when the app was working.

Things you can do

  • Reinstall ionic
  • Remove platforms, add them again
  • Remove node_modules and run npm install again
  • Check your dependencies if they are supported by the ionic version

Let me know.


#11

I don’t use a versioning system, and I only have a save of the www folder and not one for the full project.
I’ll try this tomorrow, and I’ll write you at this moment. Thank you for your answers.


#12

Start with versioning system like GIT (Bitbucket or something) from tomorrow. It will help you a lot.


#13

Good morning,

I tried to reinstall Ionic, I also removed the android platform and add this platform again, but this changed nothing. How can check if my dependencies are supported by this Ionic version ?


#14

I finally found the solution. I don’t know why it happened at the same moment as the update, but I just had to change the browser (from Firefox to Chrome) xD Thanks for your help ! I can work again xD