App does not works on mobile connection but works with wifi on iOS

Ionic version: (check one with “x”)
[x] 1.7.16
[ ] 2.x

I’m submitting a … (check one with “x”)
[ ] bug report
[ ] feature request
[x] support request

Current behavior:

Hi, I’m running into issue on iOS since iOS 10.x update.

When I start the app everything works fine if I use WIFI connection, every view is correctly loaded ad I can use it normally.
This does not happen if I use mobile connection, the app is not able to contact my server and database. If I try to login it fails and says “incorrect credentials” even if there are correct and if I switch from wifi to mobile when I’m running the app, the first thing to be load fails and all the app become empty. Also, if i try several times to use mobile, killing the app, it stucks on a white screen and the only way to use it again is to uninstall and install again. I tryed lots of possibly solutions and none works. The only thing I can imagine is the new CSP but tried tons of string, without success

Expected behavior:

I should be able to use mobile and wifi connection without any problem.

Steps to reproduce:

Related code:
This is my CSP tag

<meta http-equiv="Content-Security-Policy" content="frame-src * gap://ready; default-src 'self' gap://ready file://* *; connect-src * blob: data:; style-src * 'unsafe-inline'; script-src * 'unsafe-eval' 'unsafe-inline'; img-src data: *">```

Ionic info:

Cordova CLI: 6.5.0
Gulp version: CLI version 3.9.1
Gulp local: Local version 3.9.1
Ionic CLI Version: 1.7.16
Ionic App Lib Version: 0.7.3
OS: Distributor ID: Ubuntu Description: Ubuntu 16.04.1 LTS
Node Version: v4.2.6

Just to make sure, you are not running your server/apis from within your wifi network aren’t you!
If you are not, then try to debug mode from Chrome’s Inspect Mode and check the log what it says.

Hi nbamj,

I tried already, with xcode and safari web inspect. It says nothing, the only thing I can see changing is that on wifi the network requestes are ok, but in mobile they don’t resolve. It’s like the phone is not connected to internet (and it is).

And my server api is not running from within my wifi network, and before iOS 10 update it worked as expected as is working on Android, both on wifi and mobile.

1 Like

Define please. How do you know?

It never stops to load

and if I check the network requests they never get response…

I am having the same issue. Did you ever resolve this?

The app works fin on Android (Wifi and network), but only works on wifi in the iOS build.

IOS 10 onward needs IP V6 Network. Is any one of your call violating IP V6 restrictiosn. verify and then check

HI guys,

my problem was caused from a dynatrace file that has an error and iOS blocks my connection due to this.

Hope you find a solution for your problem.

How do you check that file “dynatrace file”

DId any one of you find solution to this issue. What is this dynatrace file and how to fix this issue.

The problem was my iPhone mobile data. In settings-> Cellular , my application was disabled, due to which it was not allowed to use mobile data. Enabling it, fixed my issue.

1 Like