App.bundle.js not being created - breaking app


#1

app.bundle.js is not being created under www/build/js (404 not found error) .
I have tried beta 8 & 9 and many combinations in my package.json but still it does not get created.
I have tried making a new project and used gulp build which does create it but when I replace the app folder with mine it does not create it.
i do get some errors when compiling but nothing which caused breaks before and nothing in red just stuff like “property cordova does not exist on window” etc.

It does create es6, reflect and zone js files but nothing else.


#2

Yeah I’ve just got this too, suddenly nothing working. Any ideas?


#3

This worked for me from: Ionic 2 Not Generating app.bundle.js

In package.json:

I changed to "ionic-gulp-browserify-typescript": "1.1.0", (removed the caret) and ran npm install. Then things started working.


#4

Yeah i got that working using the same thing, now my web version works but my native ones crash on load, are you having this problem also?


#5

No I’m not, but I’ve had hell today just getting everything working again.

Ended up reinstalling the cordova framework, updating ionic CLI, removing ios + android platforms using ionic CLI and, re-adding + any plugins. HELL!

But it’s working now. Sorry if that’s not what you wanted to hear!


#6

Glad to know it’s not just me going through hell, last two days have been a nightmare, been doing much of the same, one problem on top of the next and I’d be lucky to get an error message telling me why. I may have to start from scratch at this rate which is going to take up soo much time and we’ll probably be doing it all over again on the next update :frowning:


#7

I keep a backup of the /app folder in my dropbox.

If load of stuff happens like this, I generally just remove everything and the drop the /app folder back in. Might save you a few hours next time it happens.

Good luck!


#8

As I posted in the other topic…