Angularfire2 está dando erro de exportação com o FirebaseListObservable


#1

C:/Users/ADRIANO/Amaveis/node_modules/angularfire2/database/index"’ has no exported member ‘FirebaseListObservable’.

import { AngularFireDatabase, FirebaseListObservable } from ‘angularfire2/database’;

segue meu package.json
{
“name”: “Amaveis”,
“version”: “0.0.1”,
“author”: “Ionic Framework”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
"@angular/common": “4.4.4”,
"@angular/compiler": “4.4.4”,
"@angular/compiler-cli": “4.4.4”,
"@angular/core": “4.4.4”,
"@angular/forms": “4.4.4”,
"@angular/http": “4.4.4”,
"@angular/platform-browser": “4.4.4”,
"@angular/platform-browser-dynamic": “4.4.4”,
"@ionic-native/core": “4.3.2”,
"@ionic-native/splash-screen": “4.3.2”,
"@ionic-native/status-bar": “4.3.2”,
"@ionic/storage": “2.0.1”,
“angularfire2”: “^5.0.0-rc.3”,
“firebase”: “^4.6.0”,
“ionic-angular”: “3.8.0”,
“ionicons”: “3.0.0”,
“rxjs”: “5.4.3”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.18”
},
“devDependencies”: {
"@ionic/app-scripts": “3.0.1”,
“typescript”: “2.3.4”
},
“description”: “An Ionic project”
}

Me ajudem por favor


#2

In AngularFire 5.0 FirebaseListObservable has been replaced by AngularFireList.
https://github.com/angular/angularfire2/blob/master/docs/version-5-upgrade.md