androidManifest.xml doesn't update during Ionic Package tool

Hi to all.
today i find a issue (probably) on Ionic package tool.
I was trying to build my app for Android platform using these new cool feature and i could not understand why the device doesn’t show me all permissions nedded, in detail:

<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />

and the default ones
<uses-permission android:name="android.permission.INTERNET" />

after installing the app the geolocation doesn’t work.
So i decompiled the apk and i saw that the androidManifest.xml doesn’t had the first two permissions above.

I tryed a lot of time, but nothing; and i decided to build the apk manualy and now it work good.

someone else has encountered the same problem?
many thanks

Just making sure, but did you install the cordova geolocation plugin? Be sure it got installed to the plugin folder.

If so, try removing the android platform and adding it back. ionic platform remove android then add it back again.

I had a similar issue a while back and removing the platform did the trick for me.


Everything is installed correctly, because if i try to run via “ionic run android” all is working fine.
I tried to remove android platform and add it back, but nothing change; androidManifest.xml keep only android.permission.INTERNET

Furthermore i saw that the apk generate from ionic package tool is so light than the apk generated from ionic build android --release

ionic package tool: ∼4,4MB
ionic build android --release: ∼26.8MB

I’m also having the same problem!

Before normally worked the “ionic package”. But recently, it does not add more the “geolocation” the app.

This is very tragic :frowning:

The solution is:

In file “.gitignore”. remove “/plugins” and “node_modules/” lines

And include plugin list names in file “package.json”, in cordovaPlugins: [ ... ]

Thanks for your response .