Xcode 8 error code 1 on launch (ios10) and can't run

Hi, after the last keynote, i tried to run the app on an iphone 5s with ios10
ionic run ios --device work but after installing the app on the phone i get this log

Traceback (most recent call last):
  File "/tmp/AD3C0B39-DF01-4837-A896-5C74DD31CE7A/fruitstrap_ef60b1c816ba3dc86238f130fb66a30fa980e4e8.py", line 36, in run_command

    lldb.target.Launch(lldb.SBLaunchInfo(shlex.split(args[1] and args[1] or '')), error)
IndexError: list index out of range

(lldb)     safequit

Application has not been launched

Error: Error code 1 for command: ios-deploy with args: --justlaunch,--no-wifi,-d,-b,/space/www/applications/wav/platforms/ios/build/device/Salons.app

On iphone 4s iOS8 i get.

------ Debug phase ------
Starting debug of iPhone 4S 'iPhone de Jean-Paul' (b274a53858027eb3c62c5ae1bebca0ae676273a1) connected through USB...

[  0%] Looking up developer disk image

2016-09-14 14:59:25.237 ios-deploy[72338:635193] [ !! ] Unable to mount developer disk image. (e8000033)

Error: Error code 253 for command: ios-deploy with args: --justlaunch,--no-wifi,-d,-b,/space/www/applications/wav/platforms/ios/build/device/Salons.app

This may help you. Update your ios-deploy (sudo npm install -g ios-deploy). For me updating it to newest version helped.

If this may not work for you then check for below process.

Start Xcode and open your .xcodeproj the file which can be found in your project_name/platforms/ios directory. Once the project is finished loading then from the top menu select Product and then select a destination and choose your new ios device.

Then click run in Xcode you will be prompted that it cannot run on the new ios device because of your code signing provisioning profile. There will be an option that says something like “try and fix it” or “Fix issue” and simply select that option and follow the prompts. Confirm/Choose which provisioning profile you want to use to deploy your app to the device.

Now the app will now run on your device.
And from now onwards you should be able to deploy to this device using the ionic run ios --device command.


Thank you so much for this!!
For the latest macOS versions, you should run npm install -g ios-deploy --unsafe-perm=true without sudo. For me it worked better!