Xcode 7.1 iOS 9.1 Failed to load webpage with error: Could not connect to the server


#1

Hi ionites. After updating to El Capitan, XCode 7.1 and iOS 9.1, my app stop working thowing the error: Failed to load webpage with error: Could not connect to the server. and remain stuck on the splashscreen. I do apply all the patches and still doesn’t work as expected. Any advice or help please !?


#2

Maybe that helps:

read the part “App Transport Security” of this blog post:
http://blog.ionic.io/preparing-for-ios-9/

And try this:


#3

Now it passes the splashscreen but give the white screen. I gotta also specify that when i run the HTML | CSS | Javascript in chrome, it works normally; which means i don’t have a problem in those codes. What can be the issue now !?


#4

Bengtler, i’ve done everything you suggest. I’ve also updated ionic cli, updated the project, removed plugins and platform and re-add them all again and the app still stuck in the white screen after the splashscreen fade out either on a real device with iOS 9.1 or the simulator. What else can or should be done please !?

Thanks in advance for your help !


#5

make a codepen with your app so we can have a look.

Are your template Paths correct --> without leading ‘/’! ?


#6

I have the same problem here.


#7

I finally resolve the issue. It was related to some plugin i was using in the app. I also update the system like npm - cordova - ionic, remove the plugins and re-add them, applied the fixes for iOS 9 and everything is good now. If anyone is dealing with such issue, try to do the same !

Thank you !

Regards from Haiti :smile:


#8

thanks for letting us know!

greets from sunny (but cold) germany :grin:


#9

It’s 3:39 AM here very cool ! :smile: Not too hot and never cold as in Germany !


#10

Bengtler, how are you doing. I’m having some trouble archiving my app to submit it to the store now. It throws the error :

chmod: Unable to change file mode on /Users/josnyjsevere/Library/Developer/Xcode/DerivedData/Lenkop-cxqapogmmkxovubpyecuzomxgaiq/Build/Intermediates/ArchiveIntermediates/Lenkop/InstallationBuildProductsLocation/Applications/Lenkop.app/www/regis/user.html: Operation not permitted

What can be done to solve this please !?


#11

maybe only your root user has access to the folder? sry i am not a mac-user :wink: But the chmod is on all unix system a tool to change access permissions to a file (read, write, execute). And the xcode user seems to not have the correct permissions.


#12

Yes, it was related with that and i had to run chown instead of chmod to make it work. Now the app is submitted to the app store for review ! Thank you :slight_smile:


#13

Hi - I’m trying to fix this problem…can you remember which plugins you were using. I have a lot (12+) and manually removing/adding them one by one is a real pain.

Many thanks, James


#14

I have:

  • Device
  • Geolocation
  • Google-Analytics
  • Splashscreen
  • Status Bar
  • Whitelist
  • X-Socialsharing
  • Local Notification
  • Keyboard
  • Dialogs
  • Globalization
  • InAppBrowser
  • AppRate

#15

Thanks @josnyS -there’s quite a bit of overlap with my list. Hopefully, I can figure out which plugin it is specifically and post back.


[Continue] Xcode 7.1 iOS 9.1 Failed to load webpage with error: Could not connect to the server
#16

I solved it by just rebooting my mac