Windows 10 unhandled exception


#1

When I try to run my app on Windows 10 using Visual Studio since RC.0 I get the following error:

Unhandled exception at line 3, column 16552 in ms-appx-web://myapp/www/build/polyfills.js

0x8000ffff - JavaScript runtime error: Argument not optional

I’ve tried removing and adding the Windows platform, removing node_modules and reinstalling, and updating Cordova, but the problem persists.

The build process itself runs fine, and if I run ionic run windows from the command line the app installs and starts but doesn’t work (I see the start page but cannot click on anything)


#2

Try this:

ionic run windows --archs=x64

Use the target architecture that you wish.


#3

I’m having the same problem, and I tried what you suggested. But I’m stuck on a problem in the cli

Before installing this app, you need to do the following:


    - Install the signing certificate


    Administrator credentials are required to continue.  Please accept the UAC prompt and provide your administrator password if asked.


Press Enter to continue...:

But hitting Enter doesn’t do anything. And if I try in an elevated command prompt, it tells me to go back to non-elevated command prompt.

Any suggestions?


#4

For the application to run you need to install the certificate. Only once.

For this, you must execute the “.ps1” file generated. Use right-click and “Execute with PowerShell”. This “.ps1” file will install the certificate and any components needed.


#5

I think the issue was I needed Set-ExecutionPolicy RemoteSigned run first. Seems to have allowed me to move past this issue. But now I have a new problem.

ionic run windows --emulator --archs=x86

It deploys to the emulator, but then crashes right away with the following error.

Exception calling "ActivateApplication" with "4" argument(s): "The remote procedure call failed. (Exception from

HRESULT: 0x800706BE)"
At C:\repos\test\platforms\windows\cordova\lib\WindowsStoreAppUtils.ps1:164 char:5
+     $appActivator.ActivateApplication($applicationUserModelId,$null,[ ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : COMException

#6

I’ve opened up an issue on GitHub regarding this. I reverted back RC1 (which fixed the issue) until this is looked into.