WhiteScreen after Splash of 10seconds

Can anyone tell me how to remove the white screen which is being displayed after the Splash screen?

What is your ionic info output?
How are you building your app?
What is your app doing on startup?

Do you permanently get a white screen or only for these 10 seconds?

@saikumar3786 Sounds like this is due to a loading error with your HTML/CSS/Javascript.

Have you tried something like:

ionic cordova run android --prod


ionic cordova run ios--prod

Normally I get the white screen after the splash when I’m testing the application without the --prod flag.

ionic info is showing some Fatal Exception @Sujan12. Bt I’m unable to show u all that error.
And the Application is working well. Bt whenever it is clicked in mobile…it is showing the Splash Screen for the duration we set and immediately after the Splash Screen,it is showing White Screen for 10 seconds…

Ok, so you have the splash screen disappear before the app has actually loaded - which shows as a white screen.

The advice @mclemcrew posted about using --prod should help a lot.

That is not good and should not be. Can you post the output?

Hello @Sujan12…I’m getting error like below when i’m even trying to know ionic version…please help me in this. Thank you in advance

That is the output of ionic info?

Run ionic -v please.
Run npm list -g --depth=0 please.
Post the content of your project’s package.json please.

As u suggested me, ionic -v also showing the same Fatal Exception error as I previously uploaded image.
my Package.json is as follows:
“name”: “myApp”,
“version”: “0.0.1”,
“author”: “Ionic Framework”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
“dependencies”: {
"@angular/common": “4.1.3”,
"@angular/compiler": “4.1.3”,
"@angular/compiler-cli": “4.1.3”,
"@angular/core": “4.1.3”,
"@angular/forms": “4.1.3”,
"@angular/http": “4.1.3”,
"@angular/platform-browser": “4.1.3”,
"@angular/platform-browser-dynamic": “4.1.3”,
"@ionic-native/core": “3.12.1”,
"@ionic-native/splash-screen": “3.12.1”,
"@ionic-native/status-bar": “3.12.1”,
"@ionic/storage": “2.0.1”,
“cordova-android”: “^6.2.3”,
“cordova-plugin-console”: “^1.0.5”,
“cordova-plugin-device”: “^1.1.4”,
“cordova-plugin-network-information”: “^1.3.3”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.2”,
“cordova-plugin-whitelist”: “^1.3.1”,
“ionic-angular”: “3.6.0”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“rxjs”: “5.4.0”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.12”
“devDependencies”: {
"@ionic/app-scripts": “2.1.3”,
"@ionic/cli-plugin-cordova": “1.6.2”,
"@ionic/cli-plugin-ionic-angular": “1.4.1”,
“ionic”: “3.7.0”,
“typescript”: “2.3.4”
“description”: “An Ionic project”,
“cordova”: {
“plugins”: {
“cordova-plugin-console”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-whitelist”: {},
“ionic-plugin-keyboard”: {},
“cordova-plugin-network-information”: {}
“platforms”: [

Please edit your post, it is not very readable at the moment.
Use the </> button above the input field to format your code, command line output or error message (select the text first, then click the button or wrap it in ``` manually). Check the preview if it looks better. This will make sure your text is readable and if it recognizes the programming language it also automatically adds code syntax highlighting. Thanks.

You missed the second command to run.
Also run ionic -v in another, non-project folder, please.

    "name": "myApp",
    "version": "0.0.1",
    "author": "Ionic Framework",
    "homepage": "http://ionicframework.com/",
    "private": true,
    "scripts": {
        "clean": "ionic-app-scripts clean",
        "build": "ionic-app-scripts build",
        "lint": "ionic-app-scripts lint",
        "ionic:build": "ionic-app-scripts build",
        "ionic:serve": "ionic-app-scripts serve"
    "dependencies": {
        "@angular/common": "4.1.3",
        "@angular/compiler": "4.1.3",
        "@angular/compiler-cli": "4.1.3",
        "@angular/core": "4.1.3",
        "@angular/forms": "4.1.3",
        "@angular/http": "4.1.3",
        "@angular/platform-browser": "4.1.3",
        "@angular/platform-browser-dynamic": "4.1.3",
        "@ionic-native/core": "3.12.1",
        "@ionic-native/splash-screen": "3.12.1",
        "@ionic-native/status-bar": "3.12.1",
        "@ionic/storage": "2.0.1",
        "cordova-android": "^6.2.3",
        "cordova-plugin-console": "^1.0.5",
        "cordova-plugin-device": "^1.1.4",
        "cordova-plugin-network-information": "^1.3.3",
        "cordova-plugin-splashscreen": "^4.0.3",
        "cordova-plugin-statusbar": "^2.2.2",
        "cordova-plugin-whitelist": "^1.3.1",
        "ionic-angular": "3.6.0",
        "ionic-plugin-keyboard": "^2.2.1",
        "ionicons": "3.0.0",
        "rxjs": "5.4.0",
        "sw-toolbox": "3.6.0",
        "zone.js": "0.8.12"
    "devDependencies": {
        "@ionic/app-scripts": "2.1.3",
        "@ionic/cli-plugin-cordova": "1.6.2",
        "@ionic/cli-plugin-ionic-angular": "1.4.1",
        "ionic": "3.7.0",
        "typescript": "2.3.4"
    "description": "An Ionic project",
    "cordova": {
        "plugins": {
            "cordova-plugin-console": {},
            "cordova-plugin-device": {},
            "cordova-plugin-splashscreen": {},
            "cordova-plugin-statusbar": {},
            "cordova-plugin-whitelist": {},
            "ionic-plugin-keyboard": {},
            "cordova-plugin-network-information": {}
        "platforms": [
1 Like

Sorry for sending unformatted code…And I run ionic -v in non-project also. Bt same error is existing…

Then it may be a deeper issue. Try running npm list -g --depth=0

Here is the output of npm list -g --depth=0

Here Sai(My Username)
and Trading(Sample application name)

I have no idea why you have all these errors here.

If I were you, I would uninstall node completely and remove everything of it from my computer. Then download and install nvm-windows and use that to install a new node version. Then run npm i -g ionic cordova again. Then ionic info should work. Bit of work, but makes sure you have a good system in place then.

OK thank you @Sujan12. I’ll try this.