Whitelist plugin not working on specific device Android


I don’t know why but I have a samsung tablet working fine even without the whitelist plugin and my friend (who is not in the same city) can’t log in into the app. So I supposed it was the whitelist plugin, I installed it and worked fine for him.

Now I’ve upgrade to cordova 5 and it’s not working for him anymore. I tried to remove and re add the plugin, to add the meta, the allow-intent and origin in the config.xml but nothing is working.

<meta http-equiv="Content-Security-Policy" content="default-src *; style-src 'self' 'unsafe-inline'; script-src * 'unsafe-inline' 'unsafe-eval'">


<access origin="*" /> <allow-intent href="http://*/*"/> <allow-intent href="https://*/*"/>

Why is it working on my device and not his? Why I never experienced this problem? And mostly, how to fix it? Is there some kind of test I can make him do to solve the issue?

Thanks for your help

You’re looking at this problem from a wrong perspective. Instead of changing your code you need to check what’s wrong on your friends device.

Use Remote Chrome Debugging, it’s easy to set up and you’ll find out what’s wrong with his device.

More information can be found here: http://www.gajotres.net/how-to-properly-debug-your-ionic-application/

Just look at a chapter: DEVICE DEBUGGING