White page showing after splash screen before app load

Not sure about Robin, but I haven’t yet altered the cordova seed app images at all. So I doubt it’s that. And the splash image shows, but after it goes away there is a short time where the screen is just white before the app appears.

@Robin if your seeing a while flash before the app is loaded, why don’t you move the splash screen hiding function into the controller that runs first?

As for now, it seems that AutoHideSplashScreen in config.xml isn’t honored. This is a part of my config.xml which is, as of Cordova 3.4, located in the root of my project instead of the www folder:

    <preference name="ShowSplashScreenSpinner" value="false" />
    <preference name="AutoHideSplashScreen" value="false" />

@mhartington The problem exists before I’m able to programatically hide the splash screen. So the splash screen is already hidden (and thus the white page showing) before navigator.splashscreen.hide() is called in my .run().

@udi I do already have custom splash screen images in my project.


Odd, what does the config.xml look like at your platform level? Weather it be iOS or android, you should be able disable the splash screen from fading away. I’ve done it before in my app and was able to programmatically hide the splash screen.

David this problem seems to be inherent to lots of iOS apps that show a webview on startup, even in objective-c.

This answer shows a general solution for native apps using XCode:

I’m not sure if it’s any help in PhoneGap, but I know it works in other packaging environments like Xamarin so wanted to offer it and try to shed light on the problem.

@Robin, @udi
I’m sharing with you a solution that is working for me.

1 - Install cordova.splashscreen plugin in your app. Example:

$ cd myapp
$ cordova plugin add org.apache.cordova.splashscreen


Fetching plugin "org.apache.cordova.splashscreen" via plugin registry
Installing "org.apache.cordova.splashscreen" for ios

2 - change the defaults.xml in myapp/platforms/ios/cordova/

<preference name="AutoHideSplashScreen" value="false" />
<preference name="ShowSplashScreenSpinner" value="false" />

3 - add in your controllers.js:

angular.module('starter.controllers', [])

.run(function($ionicPlatform) {
  $ionicPlatform.ready(function() {
    setTimeout(function() {
    }, 100);

After make these changes you must rebuild the app: $ ionic build ios

And try it $ ionic emulate ios

Let me know any doubt.


YES! That did the trick @gastonbesada. Super thanks. The first solution for this problem I could find on the web. I think editing defaults.xml in myapp/platforms/ios/cordova did it.

@gastonbesada it’s working nicely! Thanks so much.

I put the xml lines in my config.xml btw, instead of defaults.xml. Seems to work ok and I’m more comfortable with that.

This solution doesn’t work for me.

In my config file, I have :

<preference name="SplashScreen" value="splash" />
<preference name="AutoHideSplashScreen" value="false" />
<preference name="ShowSplashScreenSpinner" value="false" />

<feature name="SplashScreen">
    <param name="ios-package" value="CDVSplashScreen" />
    <param name="android-package" value="org.apache.cordova.SplashScreen" />

But the splashscreen disapears automatically when Ionic is ready.

I can see the view of my first state just after the splascreen disappears. But a white screen appears 1 second, and next the app appears and load data.

If in my $ionicPlatform.ready(), I put this lines :


The splashscreen disappears whatever happens.

thank’s @gastonbesada, it works for me.

@CyBeRCeD1190 : Same problem here. Do you got a solution?

Set a longer time for splash autohide in the config.xml and hide the splashcreen from your app code on device ready or ionic platform ready code.

Edit: sorry, I’ve referenced the thread title not the above discussion :-\

Check if there are some missing plugins.

Hello all and thank you for your help.
I just wanted to share what worked for me since it took me a good couple of hours :smile:

after following the instructions above in this post make sure you run:

ionic platform remove ios
ionic platform add ios

I hope this helps.

1 Like

I have tried all of the suggested solutions listed here, but still no luck. UPDATE hey @CyBeRCeD1190 and @m1crdy the fix is actually similar to @gastonbesada’s above, but with some important points outlined below!

I have seen this problem before ionic was even around, so this problem may be completely unrelated to ionic. I believe the problem has something to do with the initial load of a UIWebView on iOS.

UPDATE: The problem does in-fact involve the UIWebView in that the default behavior of the splash screen is that it fades out before the web view has had a chance to load the ionic app and as a result it will display a blank white screen until the content is loaded and displayed, however, I was able to fix this without having to dive into any of the native code. If anyone is still struggling and interested to know how, read on.

The first step was to Install the following plugin: cordova plugin add https://git-wip-us.apache.org/repos/asf/cordova-plugin-splashscreen.git

Next, in the ‘run’ function of your ionic app, you need to add the following line inside the $ionicPlatform.ready success callback:

.run(function($ionicPlatform) {
  $ionicPlatform.ready(function() {

This will set the splash screen to hide only once the app has completely loaded into the UIWebView.

Lastly, it is IMPORTANT to note that the following step be done in the correct config file:

In the root of your app directory and NOT in the platform/ios/YOUR_APP directory, open Ionic’s config.xml file and add the following preference which needs to be set to ‘false’:

<preference name="AutoHideSplashScreen" value="false" />

If you change this setting in Cordova’s default.xml or the ios app config.xml, it will revert back to ‘true’ every time you build your app. Setting this in the Ionic config.xml will ensure it is set during the build process.

Note, there is an additional preference titled ‘FadeSplashScreen’ which defaults to ‘true’ as well, but it is OK to leave it out if you still want the splash screen to fade away instead of just seeing it abruptly hide. Otherwise, add this preference as well and set it to ‘false’.

Save the config.xml file, build your project, and run on an actual device to see the result!

Hope this helps, this drove me crazy for quite some time.


@disrupt Nice to know you could lead with this issue.
If you see in my reply point 2, I suggested change param autohidesplash in defaults.xml in myapp/platforms/ios/cordova/
It is becase when cordova (ionic cli) build the app, overwrite config.xml with this param declared in defaults.xml.

As few mentioned here below steps will work for sure

  1. Install the cordova plug in
    $ cd myapp
    $ cordova plugin add org.apache.cordova.splashscreen

  2. Change the ionic config.xml file at root project level. DO NOT modify anything directly inside platform folder. ionic build will take care of that automatically.


  3. Regenerate the platform to add newly installed plugin

    ionic platform remove ios
    ionic platform add iOS

  4. Add hide() in the app controller

    .run(function ($ionicPlatform, $rootScope, $ionicPush, $cordovaPush) {
    $ionicPlatform.ready(function () {

             if (window.cordova && window.cordova.plugins.Keyboard) {
             if (window.StatusBar) {
                 // org.apache.cordova.statusbar required
  5. Re-build the project


@Mishi, @gastonbesada,
After following your suggestions and rebuild app, the issue still remains. I am build the app for android

my ionic info is :
OS: Windows 7 SP1
Node Version: v0.12.0
Cordova CLI: 5.0.0
Ionic Version: 1.0.0-rc.5
Ionic CLI Version: 1.3.22

I solved the issue by keeping additional

<preference name="SplashScreenDelay" value="10000"/>

in confix.xml

Is this solution is correct

Here is my preference values

<preference name="webviewbounce" value="false"/>
  <preference name="UIWebViewBounce" value="false"/>
  <preference name="DisallowOverscroll" value="true"/>
  <preference name="BackupWebStorage" value="none"/>
  <preference name="AutoHideSplashScreen" value="false"/>
  <preference name="ShowSplashScreenSpinner" value="false"/>

And try below code in yoiu app.js in .run function

                        setTimeout(function () {
                        }, 100);
1 Like