While build platform i got this error

#1

While building ionic platform i got this error how to resolve it ? my node version is 8.2.0.

#2

What libraries are you using in your app?
Post your ionic info and package.json please.

(I think I had a similar problem a few days ago…)

1 Like
#3

{
“name”: “callvaspa”,
“version”: “0.0.1”,
“author”: “Ionic Framework”,
“homepage”: “http://ionicframework.com/”,
“private”: true,
“scripts”: {
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”,
“ionic:build”: “ionic-app-scripts build”,
“ionic:serve”: “ionic-app-scripts serve”
},
“dependencies”: {
"@angular/common": “4.1.3”,
"@angular/compiler": “4.1.3”,
"@angular/compiler-cli": “4.1.3”,
"@angular/core": “4.1.3”,
"@angular/forms": “4.1.3”,
"@angular/http": “4.1.3”,
"@angular/platform-browser": “4.1.3”,
"@angular/platform-browser-dynamic": “4.1.3”,
"@ionic-native/core": “3.12.1”,
"@ionic-native/sim": “^4.0.1”,
"@ionic-native/splash-screen": “3.12.1”,
"@ionic-native/status-bar": “3.12.1”,
"@ionic/storage": “2.0.1”,
“DeviceInformationPlugin-master”: “file:…/…/…/Ionic_App/Plugins/DeviceInformationPlugin-master”,
“GetEmailId”: “file:///home/infraadmin/Tanmay_Data/Ionic_App/Plugins/GetEmailId”,
“Sim”: “file:///home/infraadmin/Tanmay_Data/Ionic_App/Plugins/Sim”,
“cordova-android”: “^6.2.3”,
“cordova-plugin-console”: “^1.0.5”,
“cordova-plugin-sim”: “file:…/…/…/Ionic_App/Plugins/cordova-plugin-sim-master”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.2”,
“cordova-plugin-whitelist”: “^1.3.1”,
“device”: “^0.3.8”,
“imeiplugin”: “file:…/…/…/Ionic_App/Plugins/cordova-plugin-imei-master”,
“ionic-angular”: “3.5.3”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“js-yaml”: “^3.9.0”,
“rxjs”: “5.4.0”,
“sw-toolbox”: “3.6.0”,
“yaml-parser”: “^3.5.3”,
“zone.js”: “0.8.12”,
“com.plugin.imei”: “/home/infraadmin/Tanmay_Data/Ionic_App/Plugins/cordova-plugin-imei-master”,
“com.vliesaputra.deviceinformation”: “/home/infraadmin/Tanmay_Data/Ionic_App/Plugins/DeviceInformationPlugin-master”
},
“devDependencies”: {
"@ionic/app-scripts": “2.0.2”,
"@ionic/cli-plugin-cordova": “1.5.0-alpha.36dc2f70”,
"@ionic/cli-plugin-ionic-angular": “1.4.0-alpha.36dc2f70”,
“typescript”: “2.3.4”
},
“description”: “An Ionic project”,
“cordova”: {
“plugins”: {
“cordova-plugin-console”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-whitelist”: {},
“ionic-plugin-keyboard”: {},
“cordova-plugin-sim”: {},
“com.plugin.imei”: {},
“com.vliesaputra.deviceinformation”: {}
},
“platforms”: [
“android”
]
}
}

#4

this issue is solved i just go update.js and remove require dependency of yaml parser
its working now

#5

Proper way to fix this is described here: https://github.com/vankasteelj/trakt.tv/issues/34