Whether require.js loads dependancies correctly in Ionic framework not?

Does require.js works fine with Ionic framework? If not then is there any other way to load the scripts(dependancies) in ionic framework ?