Weird behaviour of clicking fast (tapping)


#1

I am using 1.0.0 beta1 (no nightlies) and experiencing a weird bug:

Clicking fast on a tab (linked via ui-sref, but also experiencing that with buttons and ng-click) does not trigger the designated action. However, a second tap ANYWHERE on the screen THEN triggers the action.

Slow presses (i.e. finger is on the screen longer) trigger the action on release – just as expected.

Anyone aware of this bug? Any fixes to this?

Edit: nightly 1839 fixes this problem (at least regarding the tabs, will test a little further)!!!


#2

Hey, thanks for testing this with the nightly builds!
Theres been a lot of work done in the nightlies to fix some tap/scrolling issues so any feed back is appreciated!

Let me know if you find any other errors.


#3

yea, after further testing I have to report a really strange behaviour:

  • nightly 1839 fixes the tab problem
  • ng-click problem remains in the following very strange way:

I have an app page with <ion-item ng-repeat="item in box"> in an <ion-list>.
On the same page there are two buttons to change the active box, i.e. on an ng-click the controller updates $scope.box, and the <ion-list> displays the items of the now active box.
So far so good. I have encircled the bug so far to say (I know it sounds strange):

The two buttons with ng-click trigger without problems if

  • the <ion-item ng-repeat="item in box"> with its content is commented out

OR

  • the object $scope.box is edited right in the controller

The two buttons with ng-click trigger with the problems of post 1 if

  • the <ion-item ng-repeat="item in box"> with its content is not commented out

AND

  • the object $scope.box is fed by a factory

By the way, at all times the buttons fire without problems when using Chrome, they cause the problem on ios-simulator and on the device itself, when the above criteria are met.
I know this sounds extremely odd, but this is what happens.
I feeling quite helpless since the bug is so strange and I wonder if the bug’s origin can be found… I could provide you the app if you are interested.


#4

Hmm, yeah these are old specific issues :smile:

Yeah if you want to DM a link to where I can download the project, I’ll take a look at it. If I cant find the issues, I’ll get in touch with the devs about it


#5

alright, I’ve put up a plunker with a slimmed down version of the app (but same bug). I recommend you to download the zip and emulate it on the ios-simulator (as it works perfectly in chrome).
remember: “deep” clicks work, fast clicks perform no action, BUT perform their action when clicking ANYWHERE on the screen afterwards.

link: http://plnkr.co/edit/ZYjdS8ETMlrV4dUbGvmF


#6

can someone confirm this bug? Just download the http://plnkr.co/edit/ZYjdS8ETMlrV4dUbGvmF , put it into phonegap and play with the left-right buttons.


#7

Just tested it out, but couldn’t really notice any issues. I was able to change boxes with out any issues. Is everything thats in plunker there to reproduce the issue?


#8

Yes. Taking only the files from there and putting them in a newly created cordova project brings up those issues while simulating in ios-sim.

Have you tried to click on the buttons very fast (like very short mouse clicks)? Then (in my case) nothing should happen at first, and a click anywhere on the simulator screen then triggers the action.


#9

Alright, so in nightly 1893 this bug still persists.
I’ve created a little gif from the simluator to give you a better impression of what I’m talking about. Please note that I recorded my mouse clicks as well. I am swinging my mouse a bit to show that the action not just a bit delayed, it is really triggered by the next click.
The app is just the plnkr files put into the www directory of a virgin cordova project.

I’d really like this issue to be fixed, since it’s not only a problem in a simulator with a mouse, but also on the actual iphone.


#10

I just tried this again and heres what I did.

  • Downloaded a zip from plunkr
  • run ionic start myapp blank
  • replace contents in www with that from plunkr
  • ionic platform add ios
  • ionic emulate ios

And got this. Keep in mind, this uses beta 2, which just came out.