[WARN] Error occurred during command execution from a CLI plugin (@ionic/cli-plugin-cordova). Your plugins may be out of date


#1

[WARN] Error occurred during command execution from a CLI plugin (@ionic/cli-plugin-cordova). Your plugins may be out of
date.
[DEBUG] !!! ERROR ENCOUNTERED !!!
Error: The RegExp to find the DeepLinkConfigToken did not return valid data
[DEBUG] Error: The RegExp to find the DeepLinkConfigToken did not return valid data
at new BuildError
(C:\Users\me\WebstormProjects\qpp\node_modules@ionic\app-scripts\dist\util\errors.js:16:28)
at C:\Users\me\WebstormProjects\qpp\node_modules@ionic\app-scripts\dist\preprocess.js:18:21

This occurs during the prod build …local build works fine… any suggestions? My program is at a standstill now until I can publish to production


#2

Here is another case, unfortunately no response: Error running --prod

Post your ionic info output please.

Are you already on Angular 4.2? Ionic doesn’t suport angular 4.2.x yet, only 4.1.3: https://github.com/ionic-team/ionic-app-scripts/issues/1070#issuecomment-314682181


#3

Here is the package.json information with dependencies, etc… I downgraded to 4.1.3…this worked initially, but since the last CLI update, it doesn’t seem to work

“dependencies”: {
"@angular/animations": “^4.1.3”,
"@angular/common": “^4.1.3”,
"@angular/compiler": “^4.1.3”,
"@angular/compiler-cli": “^4.1.3”,
"@angular/core": “^4.1.3”,
"@angular/forms": “^4.1.3”,
"@angular/http": “^4.1.3”,
"@angular/platform-browser": “^4.1.3”,
"@angular/platform-browser-dynamic": “^4.1.3”,
"@angular/platform-server": “^4.1.3”,
"@ionic-native/camera": “^3.14.0”,
"@ionic-native/core": “^3.14.0”,
"@ionic-native/printer": “^3.14.0”,
"@ionic-native/splash-screen": “3.12.1”,
"@ionic-native/status-bar": “3.12.1”,
"@ionic/storage": “2.0.1”,
“angularfire2”: “^4.0.0-rc0”,
“cordova-browser”: “^4.1.0”,
“cordova-plugin-console”: “^1.0.7”,
“cordova-plugin-device”: “^1.1.6”,
“cordova-plugin-splashscreen”: “^4.0.3”,
“cordova-plugin-statusbar”: “^2.2.3”,
“cordova-plugin-whitelist”: “^1.3.2”,
“firebase”: “^4.1.3”,
“ion2-calendar”: “^2.0.0-beta.3”,
“ionic-angular”: “4.0.0-alpha.0”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“moment”: “^2.18.1”,
“pdfmake”: “^0.1.31”,
“promise-polyfill”: “6.0.2”,
“rxjs”: “5.4.1”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.12”
},
“devDependencies”: {
"@ionic/app-scripts": “^2.0.1-201707121621”,
"@ionic/cli-plugin-cordova": “1.5.0-alpha.18371e18”,
"@ionic/cli-plugin-ionic-angular": “1.4.0-alpha.18371e18”,
“typescript”: “2.3.4”
},
“cordovaPlugins”: [
“cordova-plugin-whitelist”,
“cordova-plugin-console”,
“cordova-plugin-statusbar”,
“cordova-plugin-device”,
“ionic-plugin-keyboard”,
“cordova-plugin-splashscreen”
],
“cordovaPlatforms”: [],
“description”: “GradeBook project”,
“cordova”: {
“plugins”: {
“cordova-plugin-console”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-whitelist”: {},
“ionic-plugin-keyboard”: {}
},
“platforms”: [
“browser”
]
}


#4

Here’s the ionic info output

C:\Users\wayne\WebstormProjects\app

global packages:

@ionic/cli-plugin-proxy : 1.4.0-alpha.18371e18
@ionic/cli-utils        : 1.6.0-alpha.18371e18
Cordova CLI             : 7.0.1
Ionic CLI               : 3.6.0-alpha.18371e18

local packages:

@ionic/app-scripts              : 2.0.1
@ionic/cli-plugin-cordova       : 1.5.0-alpha.18371e18
@ionic/cli-plugin-ionic-angular : 1.4.0-alpha.18371e18
Cordova Platforms               : browser 4.1.0
Ionic Framework                 : ionic-angular 4.0.0-alpha.0

System:

Node       : v7.7.4
OS         : Windows 10
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed
npm        : 4.1.2

#5

Yeah you should go to stable, released verisons of those.
No use in trying to debug and support alpha releases.


#6

Agreed…I’ve tried everything. What I finally got to work was downgrading back to angular 4.1.3.
In order to do this i had to remove the “^” character from the dependency lines:
Example: when it read: @angular/core": “^4.1.3”, it wouldn’t downgrade running npm update
I had to remove that character so it read: “@angular/core”: “4.1.3”, and then npm update downgraded angular.

This seems to have fixed the issue for now. Thanks for responding!


DeepLinkConfigToken did not return valid data