Version 4 or greater is required for this plugin


#1

I’m facing a problem when I execute “ionic cordova build android --release”.

Subproject Path: CordovaLib
Subproject Path: app
You are running version 3 of the Ionic CLI. Version 4 or greater is required for this plugin.
[ERROR] An error occurred while running cordova build android (exit code 255).

Any flag gives me more information about what plugins is requiring the next version of Ionic CLI.

Any help will be appreciated. Thanks in advance :slight_smile:

Here are my dependencies:

“dependencies”: {
@angular/common”: “5.0.3”,
@angular/compiler”: “5.0.3”,
@angular/compiler-cli”: “5.0.3”,
@angular/core”: “5.0.3”,
@angular/forms”: “5.0.3”,
@angular/http”: “5.0.3”,
@angular/platform-browser”: “5.0.3”,
@angular/platform-browser-dynamic”: “5.0.3”,
@ionic-native/camera”: “^4.5.3”,
@ionic-native/core”: “^4.12.0”,
@ionic-native/deeplinks”: “^4.8.0”,
@ionic-native/facebook”: “^4.12.0”,
@ionic-native/firebase”: “^4.7.0”,
@ionic-native/geolocation”: “^4.12.0”,
@ionic-native/local-notifications”: “^4.7.0”,
@ionic-native/market”: “^4.7.0”,
@ionic-native/native-geocoder”: “^4.12.0”,
@ionic-native/social-sharing”: “^4.5.3”,
@ionic-native/splash-screen”: “4.4.0”,
@ionic-native/status-bar”: “4.4.0”,
@ionic/pro”: “^1.0.20”,
@ionic/storage”: “2.1.3”,
@types/algoliasearch”: “^3.24.9”,
@types/intro.js”: “^2.4.3”,
“algoliasearch”: “^3.26.0”,
“cordova-android”: “7.0.0”,
“cordova-plugin-add-swift-support”: “^1.7.1”,
“cordova-plugin-badge”: “^0.8.7”,
“cordova-plugin-camera”: “^4.0.3”,
“cordova-plugin-device”: “^2.0.2”,
“cordova-plugin-facebook”: “^0.2.2”,
“cordova-plugin-facebook4”: “^2.5.0”,
“cordova-plugin-file”: “^6.0.1”,
“cordova-plugin-file-transfer”: “^1.7.1”,
“cordova-plugin-firebase”: “^1.1.4”,
“cordova-plugin-geolocation”: “^4.0.1”,
“cordova-plugin-ionic”: “^5.2.4”,
“cordova-plugin-ionic-keyboard”: “^2.1.3”,
“cordova-plugin-ionic-webview”: “^2.1.4”,
“cordova-plugin-local-notification”: “^0.9.0-beta.2”,
“cordova-plugin-market”: “^1.2.0”,
“cordova-plugin-nativegeocoder”: “^3.1.2”,
“cordova-plugin-splashscreen”: “^5.0.2”,
“cordova-plugin-statusbar”: “^2.4.2”,
“cordova-plugin-whitelist”: “^1.3.3”,
“cordova-plugin-x-socialsharing”: “^5.4.1”,
“cordova-promise-polyfill”: “0.0.2”,
“cordova-support-android-plugin”: “^1.0.1”,
“cordova-support-google-services”: “^1.2.0”,
“crypto-js”: “^3.1.9-1”,
“diff”: “^3.5.0”,
“emulator”: “0.1.0”,
“es6-promise-plugin”: “^4.2.2”,
“firebase”: “^4.13.1”,
“fs-extra”: “^5.0.0”,
“gherkin”: “^5.1.0”,
“has-flag”: “^3.0.0”,
“intro.js”: “^2.9.3”,
“ionic-angular”: “3.9.2”,
“ionic-plugin-deeplinks”: “^1.0.17”,
“ionic-tags-input”: “^0.1.2”,
“ionicons”: “^3.0.0”,
“js-sha256”: “^0.9.0”,
“js-yaml”: “^3.11.0”,
“limax”: “^1.6.0”,
“moment”: “^2.20.1”,
“ng-lottie”: “^0.3.1”,
“ng-socket-io”: “^0.2.4”,
“node-sass”: “^4.7.2”,
“os-name”: “^2.0.1”,
“postcss”: “^6.0.22”,
“rollup”: “^0.59.4”,
“rxjs”: “^5.5.6”,
“scandir”: “^0.1.2”,
“setimmediate”: “^1.0.5”,
“socket.io-client”: “^2.1.1”,
“sw-toolbox”: “3.6.0”,
“tslint”: “^5.10.0”,
“webpack”: “^3.8.1”,
“ws”: “^5.2.0”,
“zone.js”: “0.8.18”
}


#2

So, you need to update your CLI to the latest. Remember the CLI is NOT the same as the framework.


#3

I am getting this error as well. It is not telling me what the guilty plugin is. If I upgrade my CLI using the following:

$ npm install -g ionic@latest

I get CLI version 3.20.0.

I am occasionally asked: The Ionic CLI has an update available (3.20.0 => 4.5.0)! Would you like to install it?

I reply NO because I believe this is for Ionic 4???

Here is my current environment:

cli packages: (/usr/local/lib/node_modules)
@ionic/cli-utils : 1.19.2
ionic (Ionic CLI) : 3.20.0
global packages:
cordova (Cordova CLI) : 8.0.0
local packages:
@ionic/app-scripts : 3.2.0
Cordova Platforms : android 7.0.0 ios 4.5.5
Ionic Framework : ionic-angular 3.9.2
System:
Node : v11.2.0
npm : 6.4.1
OS : macOS High Sierra
Xcode : Xcode 10.1 Build version 10B61
Environment Variables:
ANDROID_HOME : not set
Misc:
backend : pro

I have tried backing out the following three plugins which were the last ones I installed:

“cordova-plugin-ionic”: “^5.2.7”,
@ionic/pro”: “^2.0.3”,
downgraded @ionic/app-scripts from 3.2.1 to 3.2.0

I did this by deleting my node_modules directory and my package-lock.json. I then removed the entries in the package.json file, then npm install and npm build. I was following instructions from this Ionic documentation:

I am stuck and not sure how to move forward. Any help is appreciated.