Upload app on Apple store Problem

Hello all
I have a problem that I think I have not found specific steps to solve well.
The problem is: The application cannot be uploaded to the Apple Store.
I think it’s about UIwebview
This message that comes to the developer account after uploading the application and rejecting the application

Deprecated API Usage - New apps that use UIWebView are no longer accepted. Instead, use WKWebView for improved security and reliability٫

Is there a solution? Thank you very much
This is my plugin list :::

card.io.cordova.mobilesdk 2.1.0 "CardIO"
com.paypal.cordova.mobilesdk 3.5.0 "PayPalMobile"
cordova-plugin-androidx-adapter 1.1.1 "cordova-plugin-androidx-adapter"
cordova-plugin-androidx 2.0.0 "cordova-plugin-androidx"
cordova-plugin-appavailability 0.4.2 "AppAvailability"
cordova-plugin-badge 0.8.8 "Badge"
cordova-plugin-browsertab 0.2.0 "cordova-plugin-browsertab"
cordova-plugin-camera 4.1.0 "Camera"
cordova-plugin-compat 1.2.0 "Compat"
cordova-plugin-device 2.0.3 "Device"
cordova-plugin-facebook4 6.4.0 "Facebook Connect"
cordova-plugin-fcm-with-dependecy-updated 6.4.3 "Cordova FCM Push Plugin"
cordova-plugin-file-transfer 1.7.1 "File Transfer"
cordova-plugin-file 6.0.2 "File"
cordova-plugin-filechooser 1.2.0 "File Chooser"
cordova-plugin-filepath 1.5.8 "cordova-plugin-filepath"
cordova-plugin-filepicker 1.1.6 "File Picker"
cordova-plugin-geolocation 4.0.2 "Geolocation"
cordova-plugin-globalization 1.11.0 "Globalization"
cordova-plugin-googleplus 8.5.0 "Google SignIn"
cordova-plugin-ionic-keyboard 2.2.0 "cordova-plugin-ionic-keyboard"
cordova-plugin-ionic-webview 5.0.0 "cordova-plugin-ionic-webview"
cordova-plugin-market 1.2.0 "Market"
cordova-plugin-network-information 2.0.2 "Network Information"
cordova-plugin-screen-orientation 3.0.2 "Screen Orientation"
cordova-plugin-splashscreen 5.0.4 "Splashscreen"
cordova-plugin-statusbar 2.4.3 "StatusBar"
cordova-plugin-telerik-imagepicker 2.3.3 "ImagePicker"
cordova-plugin-whitelist 1.3.4 "Whitelist"
cordova-plugin-wkwebview-engine 1.2.1 "Cordova WKWebView Engine"
cordova-plugin-x-socialsharing 5.6.8 "SocialSharing"
cordova-support-android-plugin 1.0.2 "cordova-support-android-plugin"
cordova-support-google-services 1.4.1 "cordova-support-google-services"
cordova.plugins.diagnostic 5.0.2 "Diagnostic"
es6-promise-plugin 4.2.2 "Promise"

This is my ionic Info ::::::


   Ionic CLI                     : 5.4.16 (/Users/SomeOne/.nvm/versions/node/v14.9.0/lib/node_modules/ionic)
   Ionic Framework               : @ionic/angular 5.1.1
   @angular-devkit/build-angular : 0.901.7
   @angular-devkit/schematics    : 9.1.7
   @angular/cli                  : 9.1.7
   @ionic/angular-toolkit        : 2.2.0


   Capacitor CLI   : 2.1.2
   @capacitor/core : 2.1.2


   Cordova CLI       : 10.0.0
   Cordova Platforms : ios 6.1.1
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 5.0.0, (and 27 other plugins)


   cordova-res : 0.15.1
   native-run  : 1.0.0


   ios-sim : 8.0.2
   NodeJS  : v14.9.0 (/Users/macshop/.nvm/versions/node/v14.9.0/bin/node)
   npm     : 6.14.8
   OS      : macOS Catalina
   Xcode   : Xcode 11.6 Build version 11E708

There are so so many Posts and Answers to this Topic…

Ionic Blog: https://ionicframework.com/blog/understanding-itms-90809-uiwebview-api-deprecation/

It describes the situation and how to handle it very well


I spent a whole day trying. I’ve tried ten times in a row but it’s useless I guess I don’t know how to do it well.
The truth is, this is the first time I uploaded the application on the Apple Store. I am beginning in this

The Error says that in your App UiWebView is used. As i can see in your posted Info, you are using Cordova 6.1.1. That’s “good”, because they removed all References some Versions before. The bad news is that then one of your plugin is the problem.

What i would do: open the Project in xcode and search for Text: UiWebView. Check the References and where they came from.

It can happen that you are using a old unmaintained Plugin which isn’t updated anymore. You than have the following Options:

  1. Fork the Plugin and edit yout own
  2. Check for Forks or other Plugins

this is my resulte

There you can see that the Social Sharing Plugin uses it. Try updating it to the latest Version

I did but the problem appeared again

Look here. The UIwebview has disappeared from here after update social sharing plugin .

where are these results from?

like this from

… from sezar/www

The above the social sharing. This one is away after upgrading?

The above the social sharing. This one is away after upgrading?
yes is away after upgradeing but i send image again .

The current position is shown as in this picture

have you tried to submit like this?

Yes, but the same problem has not changed

Please remove all temp folders:

  • www
  • platforms
  • plugins
  • node_modules
  • package-lock.json

And run npm install again - then rebuild your app. Same results in the search?

I remove all this and run npm install again

  • www
  • platforms
  • plugins
  • node_modules
  • package-lock.json
    now this is the result in the search
    just in tow file

Did you try to upload this Build?

Did you try to upload this Build?

no I will now