Upgrade to Ionic6 fails

Getting this when I try to follow the update procedure. Same for sudo before the install. Is it my network / npm version or a know bug?

npm install @ionic/angular@6

npm ERR! Unexpected end of JSON input while parsing near '...8sEtVUTtP+ZQth30nviPF'
npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/me/.npm/_logs/2022-03-08T22_23_45_465Z-debug.log