Updated from 4 rc to V4 -> ionicon not showing RESOLVED

#1

Hi all,

i just updated my project to V4 from 4 RC.
I also updated some other dependencies with NCU -u

Now everything works ecept the ionicons.
I get GET http://localhost:8100/svg/md-search.svg 404 (Not Found) etc.

i deleted node_modules, ran npm install again.
I have no idea how to fix this?

Can anyone help?

Here are my dependencies from package.json

"dependencies": {
    "@angular/common": "~7.2.2",
    "@angular/core": "~7.2.2",
    "@angular/fire": "^5.1.0",
    "@angular/forms": "~7.2.2",
    "@angular/http": "~7.2.2",
    "@angular/platform-browser": "~7.2.2",
    "@angular/platform-browser-dynamic": "~7.2.2",
    "@angular/router": "~7.2.2",
    "@capacitor/cli": "1.0.0-beta.14",
    "@capacitor/core": "1.0.0-beta.14",
    "@ionic-native/core": "5.0.0",
    "@ionic-native/splash-screen": "5.0.0",
    "@ionic-native/status-bar": "5.0.0",
    "@ionic/angular": "^4.0.0",
    "@ionic/pro": "2.0.4",
    "@ionic/storage": "^2.2.0",
    "@types/algoliasearch": "^3.30.1",
    "algoliasearch": "^3.30.0",
    "angularfire2": "^5.1.1",
    "cordova-sqlite-storage": "^2.6.0",
    "core-js": "^2.6.3",
    "firebase": "^5.8.1",
    "rxjs": "~6.3.3",
    "zone.js": "~0.8.29"
  },
  "devDependencies": {
    "@angular-devkit/architect": "~0.12.3",
    "@angular-devkit/build-angular": "~0.12.3",
    "@angular-devkit/core": "~7.2.3",
    "@angular-devkit/schematics": "~7.2.3",
    "@angular/cli": "~7.2.3",
    "@angular/compiler": "~7.2.2",
    "@angular/compiler-cli": "~7.2.2",
    "@angular/language-service": "~7.2.2",
    "@ionic/angular-toolkit": "^1.2.0",
    "@types/jasmine": "~3.3.0",
    "@types/jasminewd2": "~2.0.3",
    "@types/node": "~10.12.0",
    "codelyzer": "~4.5.0",
    "jasmine-core": "~3.3.0",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~4.0.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.0",
    "karma-jasmine": "~2.0.1",
    "karma-jasmine-html-reporter": "^1.4.0",
    "protractor": "~5.4.0",
    "ts-node": "~8.0.2",
    "tslint": "~5.12.1",
    "typescript": "~3.2.4"
  },
1 Like
#2

See RC.1 CHANGELOG -> https://github.com/ionic-team/ionic/blob/master/CHANGELOG.md

2 Likes
#3

OK i found the problem.
the angular.json config file changed …

this

{
     "glob": "**/*.svg",
     "input": "node_modules/@ionic/angular/dist/ionic/svg",
     "output": "./svg"
}

was changed into this:

{
                "glob": "**/*.svg",
                "input": "node_modules/ionicons/dist/ionicons/svg",
                "output": "./svg"
}

Found it when comparing everything inside a new project to my updated project.
Just in case someone stumbles across the same problem

#4

Thanks alot! While i was typing my answer you posted the link to the change log. It would have saved me some time :slight_smile: Next time. It will be first to check :slight_smile:

1 Like
#5

Between us, when I upgraded I missed the information too, that’s why I didn’t forgot it now :wink:

Cool to hear you solved the issue

#6

Hi. I tried your solution but it did not worked for me.

#7

@SammyCool look at the Link reedrichards provided to the change log. Maybe that helps you.
But if you changed the angular.json file, it should work.
Maybe run ionic repair in your cmd. Just to make sure all your files are there.

#8

Thanks for the suggestion. Thing is when I do “ionic serve” it works fine in port 8080. But since we have some memory issue we have added "serve-local": "node --max_old_space_size=5048 ./node_modules/@angular/cli/bin/ng serve" in package.json file and we do “npm run serve-local” to build with port 4200. In that case its getting the error.