Uninstall ionic


#1

I am using Windows 10 and trying to uninstall ionic and cordova.
I used the commands

npm uninstall -g ionic
npm uninstall -g cordova

I cleared the npm cache as well.

Even after doing this when i run the cordova -v it shows the version as 7.0.1 and when i run ionic info I get the following

global packages:

@ionic/cli-utils : 1.4.0
Ionic CLI        : 3.4.0

System:

Node       : v6.11.0
OS         : Windows 10
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed
npm        : 3.10.10

Any help appreciated…


#2

Run npm list -g --depth=0.


#3

C:\Users\USER_NAME\AppData\Roaming\npm
±- @angular/cli@1.2.0
±- UNMET PEER DEPENDENCY @angular/common@4.1.3
±- UNMET PEER DEPENDENCY @angular/compiler@4.1.3
±- UNMET PEER DEPENDENCY @angular/compiler-cli@4.1.3
±- UNMET PEER DEPENDENCY @angular/core@4.1.3
±- UNMET PEER DEPENDENCY @angular/forms@4.1.3
±- UNMET PEER DEPENDENCY @angular/http@4.1.3
±- UNMET PEER DEPENDENCY @angular/platform-browser@4.1.3
±- UNMET PEER DEPENDENCY @angular/platform-browser-dynamic@4.1.3
±- bower@1.8.0
±- firebase-tools@3.0.4
±- generator-angular-fullstack@4.2.2
±- grunt-cli@1.2.0
±- error: ENOENT: no such file or directory, open 'C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic\package.json
±- ionic-angular@3.5.0
±- UNMET PEER DEPENDENCY rxjs@5.4.0
±- windows-build-tools@0.6.0
±- yo@1.8.5
`-- UNMET PEER DEPENDENCY zone.js@0.8.12

npm ERR! peer dep missing: @angular/common@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/compiler@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/compiler-cli@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/core@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/forms@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/http@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/platform-browser@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: @angular/platform-browser-dynamic@4.1.3, required by ionic-angular@3.5.0
npm ERR! peer dep missing: rxjs@5.4.0, required by ionic-angular@3.5.0
npm ERR! peer dep missing: zone.js@0.8.12, required by ionic-angular@3.5.0
npm ERR! error in C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic: ENOENT: no such file or directory, open 'C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic\package.json’
npm ERR! extraneous: ionic-app-lib C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib
npm ERR! error in C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib: ENOENT: no such file or directory, open 'C:\Users\USER_NAME\AppData\Roaming\npm\node_modules\ionic\node_modules\ionic-app-lib\package.json’
npm ERR! missing: websocket-extensions@>=0.1.1, required by websocket-driver@0.5.2
npm ERR! missing: wrappy@1, required by inflight@1.0.5
npm ERR! missing: brace-expansion@^1.0.0, required by minimatch@3.0.2
npm ERR! missing: wrappy@1, required by once@1.3.3
npm ERR! missing: wrappy@1, required by inflight@1.0.5
npm ERR! missing: wrappy@1, required by once@1.3.3
npm ERR! missing: async@~1.5.0, required by googleapis@2.1.7
npm ERR! missing: gapitoken@~0.1.2, required by googleapis@2.1.7
npm ERR! missing: google-auth-library@~0.9.3, required by googleapis@2.1.7
npm ERR! missing: request@~2.65.0, required by googleapis@2.1.7
npm ERR! missing: string-template@~0.2.0, required by googleapis@2.1.7
npm ERR! missing: concat-stream@~1.4.7, required by base64url@1.0.6
npm ERR! missing: meow@~2.0.0, required by base64url@1.0.6
npm ERR! missing: buffer-equal-constant-time@^1.0.1, required by jwa@1.1.3
npm ERR! missing: ecdsa-sig-formatter@^1.0.0, required by jwa@1.1.3
npm ERR! missing: generate-function@^2.0.0, required by is-my-json-valid@2.13.1
npm ERR! missing: generate-object-property@^1.1.0, required by is-my-json-valid@2.13.1
npm ERR! missing: jsonpointer@2.0.0, required by is-my-json-valid@2.13.1
npm ERR! missing: xtend@^4.0.0, required by is-my-json-valid@2.13.1
npm ERR! missing: pinkie@^2.0.0, required by pinkie-promise@2.0.1
npm ERR! missing: asn1@~0.2.3, required by sshpk@1.9.0
npm ERR! missing: assert-plus@^1.0.0, required by sshpk@1.9.0
npm ERR! missing: dashdash@^1.12.0, required by sshpk@1.9.0
npm ERR! missing: getpass@^0.1.1, required by sshpk@1.9.0
npm ERR! missing: accepts@~1.3.3, required by compression@1.6.2
npm ERR! missing: bytes@2.3.0, required by compression@1.6.2
npm ERR! missing: compressible@~2.0.8, required by compression@1.6.2
npm ERR! missing: debug@~2.2.0, required by compression@1.6.2
npm ERR! missing: vary@~1.1.0, required by compression@1.6.2
npm ERR! missing: debug@~2.2.0, required by connect@3.4.1
npm ERR! missing: finalhandler@0.4.1, required by connect@3.4.1
npm ERR! missing: parseurl@~1.3.1, required by connect@3.4.1
npm ERR! missing: utils-merge@1.0.0, required by connect@3.4.1
npm ERR! missing: qs@~1.1.0, required by connect-query@0.2.0
npm ERR! missing: punycode@^1.3.2, required by fast-url-parser@1.1.3
npm ERR! missing: graceful-fs@^4.1.2, required by fs-extra@0.30.0
npm ERR! missing: jsonfile@^2.1.0, required by fs-extra@0.30.0
npm ERR! missing: klaw@^1.0.0, required by fs-extra@0.30.0
npm ERR! missing: path-is-absolute@^1.0.0, required by fs-extra@0.30.0
npm ERR! missing: rimraf@^2.2.8, required by fs-extra@0.30.0
npm ERR! missing: fs.realpath@^1.0.0, required by glob@7.0.5
npm ERR! missing: inflight@^1.0.4, required by glob@7.0.5
npm ERR! missing: inherits@2, required by glob@7.0.5
npm ERR! missing: once@^1.3.0, required by glob@7.0.5
npm ERR! missing: path-is-absolute@^1.0.0, required by glob@7.0.5
npm ERR! missing: glob-slash@^1.0.0, required by glob-slasher@1.0.1
npm ERR! missing: lodash.isobject@^2.4.1, required by glob-slasher@1.0.1
npm ERR! missing: toxic@^1.0.0, required by glob-slasher@1.0.1
npm ERR! missing: url-join@0.0.1, required by join-path@1.1.0
npm ERR! missing: mime-db@~1.23.0, required by mime-types@2.1.11
npm ERR! missing: brace-expansion@^1.0.0, required by minimatch@3.0.2
npm ERR! missing: basic-auth@~1.0.3, required by morgan@1.7.0
npm ERR! missing: debug@~2.2.0, required by morgan@1.7.0
npm ERR! missing: depd@~1.1.0, required by morgan@1.7.0
npm ERR! missing: flat-arguments@^1.0.0, required by nash@2.0.4
npm ERR! missing: lodash@^3.10.0, required by nash@2.0.4
npm ERR! missing: minimist@^1.1.0, required by nash@2.0.4
npm ERR! missing: ee-first@1.1.1, required by on-finished@2.3.0
npm ERR! missing: isarray@0.0.1, required by path-to-regexp@1.5.3
npm ERR! missing: array-flatten@2.0.0, required by router@1.1.4
npm ERR! missing: debug@~2.2.0, required by router@1.1.4
npm ERR! missing: methods@~1.1.2, required by router@1.1.4
npm ERR! missing: parseurl@~1.3.1, required by router@1.1.4
npm ERR! missing: path-to-regexp@0.1.7, required by router@1.1.4
npm ERR! missing: setprototypeof@1.0.0, required by router@1.1.4
npm ERR! missing: utils-merge@1.0.0, required by router@1.1.4
npm ERR! missing: strip-ansi@^3.0.0, required by string-length@1.0.1
npm ERR! missing: boxen@^0.6.0, required by update-notifier@1.0.2
npm ERR! missing: configstore@^2.0.0, required by update-notifier@1.0.2
npm ERR! missing: is-npm@^1.0.0, required by update-notifier@1.0.2
npm ERR! missing: latest-version@^2.0.0, required by update-notifier@1.0.2
npm ERR! missing: lazy-req@^1.1.0, required by update-notifier@1.0.2
npm ERR! missing: semver-diff@^2.0.0, required by update-notifier@1.0.2
npm ERR! missing: xdg-basedir@^2.0.0, required by update-notifier@1.0.2
npm ERR! missing: minimist@0.0.8, required by mkdirp@0.5.1
npm ERR! missing: fs.realpath@^1.0.0, required by glob@7.0.5
npm ERR! missing: inflight@^1.0.4, required by glob@7.0.5
npm ERR! missing: minimatch@^3.0.2, required by glob@7.0.5
npm ERR! missing: once@^1.3.0, required by glob@7.0.5
npm ERR! missing: path-is-absolute@^1.0.0, required by glob@7.0.5
npm ERR! missing: once@~1.3.0, required by end-of-stream@1.0.0
npm ERR! missing: buffer-shims@^1.0.0, required by readable-stream@2.1.4
npm ERR! missing: core-util-is@~1.0.0, required by readable-stream@2.1.4
npm ERR! missing: isarray@~1.0.0, required by readable-stream@2.1.4
npm ERR! missing: process-nextick-args@~1.0.6, required by readable-stream@2.1.4
npm ERR! missing: string_decoder@~0.10.x, required by readable-stream@2.1.4
npm ERR! missing: util-deprecate@~1.0.1, required by readable-stream@2.1.4
npm ERR! missing: pinkie@^2.0.0, required by pinkie-promise@2.0.1
npm ERR! missing: buffer-shims@^1.0.0, required by readable-stream@2.1.4
npm ERR! missing: core-util-is@~1.0.0, required by readable-stream@2.1.4
npm ERR! missing: inherits@~2.0.1, required by readable-stream@2.1.4
npm ERR! missing: isarray@~1.0.0, required by readable-stream@2.1.4
npm ERR! missing: process-nextick-args@~1.0.6, required by readable-stream@2.1.4
npm ERR! missing: string_decoder@~0.10.x, required by readable-stream@2.1.4
npm ERR! missing: util-deprecate@~1.0.1, required by readable-stream@2.1.4
npm ERR! missing: deep-extend@~0.4.0, required by rc@1.1.6
npm ERR! missing: ini@~1.3.0, required by rc@1.1.6
npm ERR! missing: minimist@^1.2.0, required by rc@1.1.6
npm ERR! missing: strip-json-comments@~1.0.4, required by rc@1.1.6
npm ERR! missing: balanced-match@^0.4.1, required by brace-expansion@1.1.6
npm ERR! missing: concat-map@0.0.1, required by brace-expansion@1.1.6
npm ERR! missing: builtin-modules@^1.0.0, required by is-builtin-module@1.0.0
npm ERR! missing: spdx-correct@~1.0.0, required by validate-npm-package-license@3.0.1
npm ERR! missing: spdx-expression-parse@~1.0.0, required by validate-npm-package-license@3.0.1
npm ERR! missing: error-ex@^1.2.0, required by parse-json@2.2.0
npm ERR! missing: is-utf8@^0.2.0, required by strip-bom@2.0.0
npm ERR! missing: graceful-readlink@>= 1.0.0, required by commander@2.9.0
npm ERR! missing: generate-function@^2.0.0, required by is-my-json-valid@2.15.0
npm ERR! missing: generate-object-property@^1.1.0, required by is-my-json-valid@2.15.0
npm ERR! missing: jsonpointer@^4.0.0, required by is-my-json-valid@2.15.0
npm ERR! missing: xtend@^4.0.0, required by is-my-json-valid@2.15.0
npm ERR! missing: asn1@~0.2.3, required by sshpk@1.10.1
npm ERR! missing: assert-plus@^1.0.0, required by sshpk@1.10.1
npm ERR! missing: dashdash@^1.12.0, required by sshpk@1.10.1
npm ERR! missing: getpass@^0.1.1, required by sshpk@1.10.1


#4

That is some strange output for that command. It should look like this or similar:

PS C:\Users\Jan\Documents> npm list -g --depth=0
C:\Program Files\nodejs
+-- cordova@7.0.1
+-- ionic@3.4.0
`-- npm@5.0.3

Well, if I were you I would just delete node from that computer (and delete all node_modules folders I can find), install nvm-windows to install new versions then.


#5

Thanks. Removed everything and started from scratch. That worked.