Unable to Use CocoaPods for Firebase When Build IOS Completes

After doing a

ionic cordova build ios

I get my Xcode project and a workspace project with two target pods xcconfig files. I then do

pod init

which creates my pod file and then I edit that to the following:

platform :ios, '9.0'

target 'MyApp' do
  pod 'Firebase/Core'

I save that and then run

pod install

I then open the workspace version (which I’m assuming was overwritten or updated by the pod install). I attempt to edit the AppDelegate.m file and immediately I know something isn’t correct since as I type this:

@import Firebase

it doesn’t autocomplete the class.

What I’ve Tried
I’ve tried creating a standalone Xcode project using Objective-C and basically did the same process I just described and it works like a charm.

I’ve tried deleting the workspace and xcconfig files initially created by the cordova ios build, and that doesn’t work either.

I’m completely stuck and I need to get this app tested and out in the next 2 weeks here. Please let me know if you have a workaround or have some update on this issue.

Do you find a solution?

I got the same issue, not sure if Pods are even needed since app working fine just google login does not work for the moment on ios.
I think the existing project misses reference to newly created Pod project that’s why it can not find the class.
Did you fix this?