Unable to see the source map when debugging on android device

I’m trying this currently using the quicklists examples in the book by Josh Morony, but it seems to be the case for any example Ionic project.
Its built and run using the commands
ionic cordova build android --debug
ionic cordova run android --debug
I’m trying to USB debug the code on an Android tablet using chrome://inspect from a Windows 7 machine.
The mapping to the original .ts files are missing. The www/build folder has files name 0.js, main.js, but the original .ts files are not shown.

What may be the problem? I posted this in another thread and slack before and did not hear back from anyone yet.

This is a link to my repo: https://github.com/vthil3049/quicklists

This is my Ionic config:

@ionic/cli-utils : 1.5.0
Cordova CLI      : 7.0.1

Ionic CLI        : 3.5.0

local packages:

@ionic/app-scripts              : 2.0.2
@ionic/cli-plugin-cordova       : 1.4.1
@ionic/cli-plugin-ionic-angular : 1.3.2
Cordova Platforms               : android 6.2.3
Ionic Framework                 : ionic-angular 3.5.2


Node       : v6.11.0
OS         : Windows 7
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed
npm        : 4.4.1

Same here.

I just updated to 3.6.0 and I don’t see any source files in Inspect. I work on Ubuntu 16.04.

My Ionic environment:

cli packages:

@ionic/cli-plugin-cordova       : 1.5.0 
@ionic/cli-plugin-ionic-angular : 1.4.0 
@ionic/cli-utils                : 1.6.0 
ionic (Ionic CLI)               : 3.6.0 

global packages:

Cordova CLI : 7.0.1 

local packages:

@ionic/app-scripts : 2.1.3
Cordova Platforms  : android 6.2.3
Ionic Framework    : ionic-angular 3.6.0


Android SDK Tools : 26.0.2
Node              : v6.11.1
OS                : Linux 4.4
npm               : 5``.3.0

I tried to run with --debug, to add "ionic_source_map_type": "#inline-source-map" to package.json as somebody suggested in another post. Nothing! Nada!

Common People! This is ridiculous! This issue has been in the air for months and months and months! It has been solved at some point and now it seems to be back again.

I really appreciate all the great work that Ionic team is doing, but this issue just makes your life a living hell. I waste hours to uncover problems that with normal debugger takes only minutes to find!

It has to be solved once and for all!

1 Like

Phew thanks @skydive , I thought I was the only one with this problem now
I hope this is solved soon and there is a permanent fix to this issue!